Closed Bug 1399483 Opened 2 years ago Closed 2 years ago

caldav broken with latest thunderbird+lightning [ReferenceError: assignment to undeclared variable in calDavCalendar.js]

Categories

(Calendar :: Provider: CalDAV, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: tschweikle, Unassigned)

Details

Attachments

(1 file, 2 obsolete files)

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/60.0.3112.105 Safari/537.36 Vivaldi/1.92.917.43

Steps to reproduce:

upgrade to todays lightning and thunderbird builds. Afterwards thunderbird could not fetch calendar from OpenExchange anymore. It seems to queery calendar data, but does not work on handled informations.




Actual results:

calendars using caldav are not shown anymore, regardless of protocol (https, https) or login required.


Expected results:

Calendars shall be fetched and displayed.
Application Basics
Name 	Thunderbird
Version 	57.0a1
Build ID 	20170911030208
Update History 	Show Update History
Update Channel 	nightly
User Agent 	Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:57.0) Gecko/20100101 Thunderbird/57.0a1
OS 	Windows_NT 6.1
Profile Folder 	Open Folder (Local drive)
Enabled Plugins 	about:plugins
Build Configuration 	about:buildconfig
Memory Use 	about:memory
Performance 	about:performance
Registered Service Workers 	about:serviceworkers
Multiprocess Windows 	0/0 (Disabled)
Stylo 	false (disabled by build)
Google Key 	Missing
Mozilla Location Service Key 	Missing
Safe Mode 	false
Profiles 	about:profiles
Mail and News Accounts
ID 		Incoming server 	Outgoing servers
Name 	Connection security 	Authentication method 		Name 	Connection security 	Authentication method 	Default?
account2		(none) Local Folders	plain	passwordCleartext
account3		(rss) Feeds	plain	passwordCleartext
account4		(im) prpl-facebook	plain	0
account5		(im) prpl-gtalk	plain	0
account6		(nntp) news.individual.de:563	SSL	passwordCleartext		smtp.gmail.com:465	SSL	OAuth2	true
account8		(im) prpl-jabber	plain	0
account10		(nntp) news.gmane.org:120	plain	passwordCleartext		smtp.gmail.com:465	SSL	OAuth2	true
account12		(imap) mail-muc.xx:993	SSL	passwordCleartext		mail-muc.xx:25	plain	none	true
Crash Reports for the Last 3 Days
Report ID 	Submitted

All Crash Reports

This application has not been configured to display crash reports.
Extensions
Name 	Version 	Enabled 	ID
.vcs Support	0.6.4	true	{efcbec50-6821-11db-bd13-0800200c9a66}
Account Colors	9.2	true	accountcolors@DW-dev
Auto Resize Image	0.14.5	true	AutoResizeImage@gmail.com
AutoarchiveReloaded	0.9.9.3	true	AutoarchiveReloaded@brummolix.addons.mozilla.org
Colored Diffs	0.7	true	{282C3C7A-15A8-4037-A30D-BBEB17FFC76B}
Display Quota	0.3.7	true	{c1ac4523-76c2-9995-adbd-d93bf5141bea}
Dropbox for Filelink	1.0.1	true	thunderbird-filelink-dropbox@mikeconley.ca
Enigmail	2.0a1pre	true	{847b3a00-7ab1-11d4-8f02-006008948af5}
Extension List Dumper	1.15.2.1-signed.1-signed	true	extensionlistdumper@sogame.cat
FiltaQuilla	1.3.2	true	filtaquilla@mesquilla.com
FoxClocks	4.2.3	true	{d37dc5d0-431d-44e5-8c91-49419370caa1}
Gantt View	1.0.0.4	true	{1510928E-A4FA-43C2-A9AF-99E521B90BC5}
Lightning	5.9a1	true	{e2fda1a4-762b-4020-b5ad-a41df1933103}
LookOut	1.2.13	true	lookout@aron.rubin
Mail Redirect	0.9.1	true	{CC3C233D-6668-41bc-AAEB-F3A1D1D594F5}
Mark All Read Button	0.7.1	true	{DA506923-55C4-4fbe-9E4C-D24B80D7DE9F}
Nextcloud for Filelink	1.5	true	owncloud@viguierjust.com
Provider for Google Calendar	3.8a1	true	{a62ef8ec-5fdc-40c2-873c-223b8a6925cc}
Quick Locale Switcher	1.7.8.5.1-signed.1-signed	true	{25A1388B-6B18-46c3-BEBA-A81915D0DE8F}
Send Later	6.3	true	sendlater3@kamens.us
Sieve	0.2.2	true	sieve@mozdev.org
SQLite Manager	0.8.3.1-signed.1-signed	true	SQLiteManager@mrinalkant.blogspot.com
Thunderbird Chat Notification	1.3.0	true	tbchatnotification@forrest79.net
uBlock Origin	1.13.8	true	uBlock0@raymondhill.net
WebDAV for Filelink	1.5	true	cloudfile-webdav@mozilla.kewis.ch
Xpunge	0.6	true	{786abda0-fd14-d247-bf69-38b2fc18491b}
Add-on Update Checker	2.15	false	{891f0410-aaa2-11e0-9f1c-0800200c9a66}
Before Tabs Toolbar	1.6	false	btt@paenglab.ch
Launchy	4.4.0.1-signed.1-let-fixed.1-signed	false	launchy@gemal.dk
MailHops	3.1.4	false	thunderbird@mailhops.com
Mnenhy	0.8.6.1-signed.1-let-fixed.1-signed	false	{bf591015-b599-4125-9428-3cb746ddca31}
quickFilters	3.2.1	false	quickFilters@axelg.com
QuickFolders	4.7.1	false	quickfolders@curious.be
Remove Duplicate Messages (Alternate)	0.3.12	false	{a300a000-5e21-4ee0-a115-9ec8f4eaa92b}
SmartTemplate4	1.4	false	smarttemplate4@thunderbird.extension
Graphics
Features
Compositing	Basic
Asynchronous Pan/Zoom	none
WebGL 1 Driver WSI Info	EGL_VENDOR: Google Inc. (adapter LUID: 0000000000000000) EGL_VERSION: 1.4 (ANGLE 2.1.0.dec065540d5f) EGL_EXTENSIONS: EGL_EXT_create_context_robustness EGL_ANGLE_d3d_texture_client_buffer EGL_ANGLE_query_surface_pointer EGL_ANGLE_window_fixed_size EGL_ANGLE_keyed_mutex EGL_ANGLE_surface_orientation EGL_NV_post_sub_buffer EGL_KHR_create_context EGL_EXT_device_query EGL_KHR_image EGL_KHR_image_base EGL_KHR_gl_texture_2D_image EGL_KHR_gl_texture_cubemap_image EGL_KHR_gl_renderbuffer_image EGL_KHR_get_all_proc_addresses EGL_KHR_stream EGL_KHR_stream_consumer_gltexture EGL_NV_stream_consumer_gltexture_yuv EGL_ANGLE_flexible_surface_compatibility EGL_ANGLE_create_context_webgl_compatibility EGL_CHROMIUM_create_context_bind_generates_resource EGL_EXTENSIONS(nullptr): EGL_EXT_client_extensions EGL_EXT_platform_base EGL_EXT_platform_device EGL_ANGLE_platform_angle EGL_ANGLE_platform_angle_d3d EGL_ANGLE_device_creation EGL_ANGLE_device_creation_d3d11 EGL_ANGLE_experimental_present_path EGL_KHR_client_get_all_proc_addresses 
WebGL 1 Driver Renderer	Google Inc. -- ANGLE (Software Adapter Direct3D11 vs_5_0 ps_5_0)
WebGL 1 Driver Version	OpenGL ES 2.0 (ANGLE 2.1.0.dec065540d5f)
WebGL 1 Driver Extensions	GL_ANGLE_depth_texture GL_ANGLE_framebuffer_blit GL_ANGLE_framebuffer_multisample GL_ANGLE_instanced_arrays GL_ANGLE_lossy_etc_decode GL_ANGLE_pack_reverse_row_order GL_ANGLE_request_extension GL_ANGLE_robust_client_memory GL_ANGLE_texture_compression_dxt3 GL_ANGLE_texture_compression_dxt5 GL_ANGLE_texture_usage GL_ANGLE_translated_shader_source GL_CHROMIUM_bind_generates_resource GL_CHROMIUM_bind_uniform_location GL_CHROMIUM_copy_compressed_texture GL_CHROMIUM_copy_texture GL_CHROMIUM_sync_query GL_EXT_blend_minmax GL_EXT_color_buffer_half_float GL_EXT_debug_marker GL_EXT_discard_framebuffer GL_EXT_disjoint_timer_query GL_EXT_draw_buffers GL_EXT_frag_depth GL_EXT_map_buffer_range GL_EXT_occlusion_query_boolean GL_EXT_read_format_bgra GL_EXT_robustness GL_EXT_sRGB GL_EXT_shader_texture_lod GL_EXT_texture_compression_dxt1 GL_EXT_texture_filter_anisotropic GL_EXT_texture_format_BGRA8888 GL_EXT_texture_rg GL_EXT_texture_storage GL_EXT_unpack_subimage GL_KHR_debug GL_NV_EGL_stream_consumer_external GL_NV_fence GL_NV_pack_subimage GL_NV_pixel_buffer_object GL_OES_EGL_image GL_OES_EGL_image_external GL_OES_compressed_ETC1_RGB8_texture GL_OES_depth32 GL_OES_element_index_uint GL_OES_get_program_binary GL_OES_mapbuffer GL_OES_packed_depth_stencil GL_OES_rgb8_rgba8 GL_OES_standard_derivatives GL_OES_texture_float GL_OES_texture_float_linear GL_OES_texture_half_float GL_OES_texture_half_float_linear GL_OES_texture_npot GL_OES_vertex_array_object 
WebGL 1 Extensions	ANGLE_instanced_arrays EXT_blend_minmax EXT_color_buffer_half_float EXT_frag_depth EXT_shader_texture_lod EXT_texture_filter_anisotropic EXT_disjoint_timer_query MOZ_debug OES_element_index_uint OES_standard_derivatives OES_texture_float OES_texture_float_linear OES_texture_half_float OES_texture_half_float_linear OES_vertex_array_object WEBGL_color_buffer_float WEBGL_compressed_texture_s3tc WEBGL_debug_renderer_info WEBGL_debug_shaders WEBGL_depth_texture WEBGL_draw_buffers WEBGL_lose_context MOZ_WEBGL_lose_context MOZ_WEBGL_compressed_texture_s3tc MOZ_WEBGL_depth_texture
WebGL 2 Driver WSI Info	-
WebGL 2 Driver Renderer	WebGL creation failed: * Refused to create WebGL2 context because of blacklist entry: FEATURE_FAILURE_UNKNOWN_DEVICE_VENDOR
WebGL 2 Driver Version	-
WebGL 2 Driver Extensions	-
WebGL 2 Extensions	-
Direct2D	Blocked for your graphics card because of unresolved driver issues.
DirectWrite	true (6.2.9200.22164)
GPU #1
Active	Yes
Description	VMware SVGA 3D
Vendor ID	0x15ad
Device ID	0x0405
Driver Version	8.15.1.50
Driver Date	12-13-2016
Drivers	vm3dum64 vm3dum64_10 vm3dum vm3dum_10
Subsys ID	040515ad
RAM	1032
Diagnostics
ClearType Parameters	Gamma: 1,8 Pixel Structure: RGB ClearType Level: 100 Enhanced Contrast: 200 
AzureCanvasAccelerated	0
AzureCanvasBackend	skia
AzureContentBackend	skia
AzureFallbackCanvasBackend	cairo
Device Reset	Trigger Device Reset
ClearType Parameters	Gamma: 1,8 Pixel Structure: RGB ClearType Level: 100 Enhanced Contrast: 200 
Decision Log
HW_COMPOSITING	
disabled by user: Disabled by pref
D3D11_COMPOSITING	
unavailable by default: Hardware compositing is disabled
DIRECT2D	
unavailable by default: Direct2D requires Direct3D 11 compositing
D3D11_HW_ANGLE	
unavailable by default: D3D11 compositing is disabled
disabled by env: D3D11 compositing is disabled
GPU_PROCESS	
unavailable by default: Multi-process mode is not enabled
WEBRENDER	
opt-in by default: WebRender is an opt-in feature
unavailable by runtime: ANGLE is disabled
Media
Audio Backend	wasapi
Max Channels	2
Preferred Channel Layout	stereo
Preferred Sample Rate	44100
Output Devices
Name 	Group 	Vendor 	State 	Preferred 	Format 	Channels 	Rate 	Latency
Lautsprecher (High Definition Audio-Gerät)	HDAUDIO\FUNC_01&VEN_15AD&DEV_1975&SUBSYS_15AD1975&REV_1001\5&8a7c455&0&0001		Disabled	None	default: F32LE, support: S16LE F32LE	2	default: 44100, support: 44100 - 44100	0 - 0
Lautsprecher (VMware VMaudio (VMAUDIO) (WDM))	PCI\VEN_1274&DEV_1371&SUBSYS_13711274&REV_02\4&3ad87e0a&0&1088		Enabled	All	default: F32LE, support: S16LE F32LE	2	default: 44100, support: 44100 - 44100	133 - 441
Input Devices
Name 	Group 	Vendor 	State 	Preferred 	Format 	Channels 	Rate 	Latency
Mikrofon (VMware VMaudio (VMAUDIO) (WDM))	PCI\VEN_1274&DEV_1371&SUBSYS_13711274&REV_02\4&3ad87e0a&0&1088		Enabled	All	default: F32LE, support: S16LE F32LE	1	default: 44100, support: 44100 - 44100	133 - 441
Mikrofon (High Definition Audio-Gerät)	HDAUDIO\FUNC_01&VEN_15AD&DEV_1975&SUBSYS_15AD1975&REV_1001\5&8a7c455&0&0001		Disabled	None	default: F32LE, support: S16LE F32LE	2	default: 44100, support: 44100 - 44100	0 - 0
Mikrofon (HD Webcam C525)	USB\VID_046D&PID_0826&MI_00\7&251b8c46&0&0000		Disabled	None	default: F32LE, support: S16LE F32LE	1	default: 48000, support: 48000 - 48000	0 - 0
Eingang (VMware VMaudio (VMAUDIO) (WDM))	PCI\VEN_1274&DEV_1371&SUBSYS_13711274&REV_02\4&3ad87e0a&0&1088		Enabled	None	default: F32LE, support: S16LE F32LE	2	default: 44100, support: 44100 - 44100	133 - 441
CD-Audio (VMware VMaudio (VMAUDIO) (WDM))	PCI\VEN_1274&DEV_1371&SUBSYS_13711274&REV_02\4&3ad87e0a&0&1088		Disabled	None	default: F32LE, support: S16LE F32LE	1	default: 44100, support: 44100 - 44100	0 - 0
Telefonleitung (VMware VMaudio (VMAUDIO) (WDM))	PCI\VEN_1274&DEV_1371&SUBSYS_13711274&REV_02\4&3ad87e0a&0&1088		Enabled	All	default: F32LE, support: S16LE F32LE	1	default: 44100, support: 44100 - 44100	133 - 441
Video (VMware VMaudio (VMAUDIO) (WDM))	PCI\VEN_1274&DEV_1371&SUBSYS_13711274&REV_02\4&3ad87e0a&0&1088		Disabled	None	default: F32LE, support: S16LE F32LE	1	default: 44100, support: 44100 - 44100	0 - 0
Aux (VMware VMaudio (VMAUDIO) (WDM))	PCI\VEN_1274&DEV_1371&SUBSYS_13711274&REV_02\4&3ad87e0a&0&1088		Disabled	None	default: F32LE, support: S16LE F32LE	1	default: 44100, support: 44100 - 44100	0 - 0
Important Modified Preferences
Name 	Value
accessibility.lastLoadDate	1502267317
accessibility.typeaheadfind.flashBar	0
browser.cache.disk.capacity	358400
browser.cache.disk.filesystem_reported	1
browser.cache.disk.hashstats_reported	1
browser.cache.disk.smart_size_cached_value	358400
browser.cache.disk.smart_size.first_run	false
browser.cache.disk.smart_size.use_old_max	false
dom.apps.lastUpdate.buildID	20160719030235
dom.apps.lastUpdate.mstone	50.0a1
dom.apps.reset-permissions	true
dom.max_chrome_script_run_time	0
dom.mozApps.used	true
dom.w3c_touch_events.expose	false
extensions.lastAppVersion	57.0a1
font.internaluseonly.changed	false
font.name.monospace.el	Consolas
font.name.monospace.tr	Consolas
font.name.monospace.x-baltic	Consolas
font.name.monospace.x-central-euro	Consolas
font.name.monospace.x-cyrillic	Consolas
font.name.monospace.x-unicode	Consolas
font.name.monospace.x-western	Consolas
font.name.sans-serif.el	Calibri
font.name.sans-serif.tr	Calibri
font.name.sans-serif.x-baltic	Calibri
font.name.sans-serif.x-central-euro	Calibri
font.name.sans-serif.x-cyrillic	Calibri
font.name.sans-serif.x-unicode	Calibri
font.name.sans-serif.x-western	Calibri
font.name.serif.el	Cambria
font.name.serif.tr	Cambria
font.name.serif.x-baltic	Cambria
font.name.serif.x-central-euro	Cambria
font.name.serif.x-cyrillic	Cambria
font.name.serif.x-unicode	Cambria
font.name.serif.x-western	Cambria
font.size.fixed.el	14
font.size.fixed.tr	14
font.size.fixed.x-baltic	14
font.size.fixed.x-central-euro	14
font.size.fixed.x-cyrillic	14
font.size.fixed.x-unicode	14
font.size.fixed.x-western	12
font.size.variable.el	17
font.size.variable.tr	17
font.size.variable.x-baltic	17
font.size.variable.x-central-euro	17
font.size.variable.x-cyrillic	17
font.size.variable.x-unicode	17
font.size.variable.x-western	13
general.useragent.extra.mnenhy	Mnenhy/0.8.6
gfx.driver-init.appVersion	42.0
gfx.driver-init.deviceID	0x0405
gfx.driver-init.driverVersion	8.15.1.33
gfx.driver-init.feature-d2d	false
gfx.driver-init.feature-d3d11	false
gfx.driver-init.status	2
media.gmp.storage.version.observed	1
network.automatic-ntlm-auth.allow-non-fqdn	true
network.automatic-ntlm-auth.trusted-uris	<local>,xx,10.*.*.*
network.cookie.prefsMigrated	true
network.dns.disablePrefetch	true
network.http.speculative-parallel-limit	0
network.negotiate-auth.delegation-uris	xx
network.negotiate-auth.trusted-uris	xx
network.ntlm.send-lm-response	true
network.predictor.cleaned-up	true
network.prefetch-next	false
places.database.lastMaintenance	1505117814
places.history.expiration.transient_current_max_pages	104858
plugin.disable_full_page_plugin_for_types	application/pdf
plugin.importedState	true
plugin.state.flash	0
plugin.state.npctrl	0
plugin.state.npdeployjava	0
print.printer_\\ps-muc\dru-muc-e017.print_bgcolor	false
print.printer_\\ps-muc\dru-muc-e017.print_bgimages	false
print.printer_\\ps-muc\dru-muc-e017.print_colorspace	
print.printer_\\ps-muc\dru-muc-e017.print_command	
print.printer_\\ps-muc\dru-muc-e017.print_downloadfonts	false
print.printer_\\ps-muc\dru-muc-e017.print_duplex	-811995822
print.printer_\\ps-muc\dru-muc-e017.print_edge_bottom	0
print.printer_\\ps-muc\dru-muc-e017.print_edge_left	0
print.printer_\\ps-muc\dru-muc-e017.print_edge_right	0
print.printer_\\ps-muc\dru-muc-e017.print_edge_top	0
print.printer_\\ps-muc\dru-muc-e017.print_evenpages	true
print.printer_\\ps-muc\dru-muc-e017.print_footercenter	
print.printer_\\ps-muc\dru-muc-e017.print_footerleft	&PT
print.printer_\\ps-muc\dru-muc-e017.print_footerright	&D
print.printer_\\ps-muc\dru-muc-e017.print_headercenter	
print.printer_\\ps-muc\dru-muc-e017.print_headerleft	&T
print.printer_\\ps-muc\dru-muc-e017.print_headerright	&U
print.printer_\\ps-muc\dru-muc-e017.print_in_color	true
print.printer_\\ps-muc\dru-muc-e017.print_margin_bottom	0.5
print.printer_\\ps-muc\dru-muc-e017.print_margin_left	0.5
print.printer_\\ps-muc\dru-muc-e017.print_margin_right	0.5
print.printer_\\ps-muc\dru-muc-e017.print_margin_top	0.5
print.printer_\\ps-muc\dru-muc-e017.print_oddpages	true
print.printer_\\ps-muc\dru-muc-e017.print_orientation	0
print.printer_\\ps-muc\dru-muc-e017.print_page_delay	50
print.printer_\\ps-muc\dru-muc-e017.print_paper_data	9
print.printer_\\ps-muc\dru-muc-e017.print_paper_height	11,00
print.printer_\\ps-muc\dru-muc-e017.print_paper_name	
print.printer_\\ps-muc\dru-muc-e017.print_paper_size_type	0
print.printer_\\ps-muc\dru-muc-e017.print_paper_size_unit	1
print.printer_\\ps-muc\dru-muc-e017.print_paper_width	8,50
print.printer_\\ps-muc\dru-muc-e017.print_plex_name	
print.printer_\\ps-muc\dru-muc-e017.print_resolution	121512960
print.printer_\\ps-muc\dru-muc-e017.print_resolution_name	
print.printer_\\ps-muc\dru-muc-e017.print_reversed	false
print.printer_\\ps-muc\dru-muc-e017.print_scaling	1,00
print.printer_\\ps-muc\dru-muc-e017.print_shrink_to_fit	true
print.printer_\\ps-muc\dru-muc-e017.print_to_file	false
print.printer_\\ps-muc\dru-muc-e017.print_unwriteable_margin_bottom	0
print.printer_\\ps-muc\dru-muc-e017.print_unwriteable_margin_left	0
print.printer_\\ps-muc\dru-muc-e017.print_unwriteable_margin_right	0
print.printer_\\ps-muc\dru-muc-e017.print_unwriteable_margin_top	0
print.printer_\\srvmfg01-muc.xx\drucker-muc.print_bgcolor	false
print.printer_\\srvmfg01-muc.xx\drucker-muc.print_bgimages	false
print.printer_\\srvmfg01-muc.xx\drucker-muc.print_duplex	-437918235
print.printer_\\srvmfg01-muc.xx\drucker-muc.print_edge_bottom	0
print.printer_\\srvmfg01-muc.xx\drucker-muc.print_edge_left	0
print.printer_\\srvmfg01-muc.xx\drucker-muc.print_edge_right	0
print.printer_\\srvmfg01-muc.xx\drucker-muc.print_edge_top	0
print.printer_\\srvmfg01-muc.xx\drucker-muc.print_evenpages	true
print.printer_\\srvmfg01-muc.xx\drucker-muc.print_footercenter	
print.printer_\\srvmfg01-muc.xx\drucker-muc.print_footerleft	&PT
print.printer_\\srvmfg01-muc.xx\drucker-muc.print_footerright	&D
print.printer_\\srvmfg01-muc.xx\drucker-muc.print_headercenter	
print.printer_\\srvmfg01-muc.xx\drucker-muc.print_headerleft	&T
print.printer_\\srvmfg01-muc.xx\drucker-muc.print_headerright	&U
print.printer_\\srvmfg01-muc.xx\drucker-muc.print_in_color	true
print.printer_\\srvmfg01-muc.xx\drucker-muc.print_margin_bottom	0.5
print.printer_\\srvmfg01-muc.xx\drucker-muc.print_margin_left	0.5
print.printer_\\srvmfg01-muc.xx\drucker-muc.print_margin_right	0.5
print.printer_\\srvmfg01-muc.xx\drucker-muc.print_margin_top	0.5
print.printer_\\srvmfg01-muc.xx\drucker-muc.print_oddpages	true
print.printer_\\srvmfg01-muc.xx\drucker-muc.print_orientation	0
print.printer_\\srvmfg01-muc.xx\drucker-muc.print_page_delay	50
print.printer_\\srvmfg01-muc.xx\drucker-muc.print_paper_data	1
print.printer_\\srvmfg01-muc.xx\drucker-muc.print_paper_height	11,00
print.printer_\\srvmfg01-muc.xx\drucker-muc.print_paper_name	
print.printer_\\srvmfg01-muc.xx\drucker-muc.print_paper_size_unit	0
print.printer_\\srvmfg01-muc.xx\drucker-muc.print_paper_width	8,50
print.printer_\\srvmfg01-muc.xx\drucker-muc.print_resolution	600
print.printer_\\srvmfg01-muc.xx\drucker-muc.print_reversed	false
print.printer_\\srvmfg01-muc.xx\drucker-muc.print_scaling	1,00
print.printer_\\srvmfg01-muc.xx\drucker-muc.print_shrink_to_fit	true
print.printer_\\srvmfg01-muc.xx\drucker-muc.print_to_file	false
print.printer_\\srvmfg01-muc.xx\drucker-muc.print_unwriteable_margin_bottom	0
print.printer_\\srvmfg01-muc.xx\drucker-muc.print_unwriteable_margin_left	0
print.printer_\\srvmfg01-muc.xx\drucker-muc.print_unwriteable_margin_right	0
print.printer_\\srvmfg01-muc.xx\drucker-muc.print_unwriteable_margin_top	0
print.printer_dru-muc-e017_(PCL).print_bgcolor	false
print.printer_dru-muc-e017_(PCL).print_bgimages	false
print.printer_dru-muc-e017_(PCL).print_colorspace	
print.printer_dru-muc-e017_(PCL).print_command	
print.printer_dru-muc-e017_(PCL).print_downloadfonts	false
print.printer_dru-muc-e017_(PCL).print_duplex	1515870810
print.printer_dru-muc-e017_(PCL).print_edge_bottom	0
print.printer_dru-muc-e017_(PCL).print_edge_left	0
print.printer_dru-muc-e017_(PCL).print_edge_right	0
print.printer_dru-muc-e017_(PCL).print_edge_top	0
print.printer_dru-muc-e017_(PCL).print_evenpages	true
print.printer_dru-muc-e017_(PCL).print_footercenter	
print.printer_dru-muc-e017_(PCL).print_footerleft	&PT
print.printer_dru-muc-e017_(PCL).print_footerright	&D
print.printer_dru-muc-e017_(PCL).print_headercenter	
print.printer_dru-muc-e017_(PCL).print_headerleft	&T
print.printer_dru-muc-e017_(PCL).print_headerright	&U
print.printer_dru-muc-e017_(PCL).print_in_color	true
print.printer_dru-muc-e017_(PCL).print_margin_bottom	0.5
print.printer_dru-muc-e017_(PCL).print_margin_left	0.5
print.printer_dru-muc-e017_(PCL).print_margin_right	0.5
print.printer_dru-muc-e017_(PCL).print_margin_top	0.5
print.printer_dru-muc-e017_(PCL).print_oddpages	true
print.printer_dru-muc-e017_(PCL).print_orientation	0
print.printer_dru-muc-e017_(PCL).print_page_delay	50
print.printer_dru-muc-e017_(PCL).print_paper_data	9
print.printer_dru-muc-e017_(PCL).print_paper_height	11,00
print.printer_dru-muc-e017_(PCL).print_paper_name	
print.printer_dru-muc-e017_(PCL).print_paper_size_type	0
print.printer_dru-muc-e017_(PCL).print_paper_size_unit	1
print.printer_dru-muc-e017_(PCL).print_paper_width	8,50
print.printer_dru-muc-e017_(PCL).print_plex_name	
print.printer_dru-muc-e017_(PCL).print_resolution	1515870810
print.printer_dru-muc-e017_(PCL).print_resolution_name	
print.printer_dru-muc-e017_(PCL).print_reversed	false
print.printer_dru-muc-e017_(PCL).print_scaling	1,00
print.printer_dru-muc-e017_(PCL).print_shrink_to_fit	true
print.printer_dru-muc-e017_(PCL).print_to_file	false
print.printer_dru-muc-e017_(PCL).print_unwriteable_margin_bottom	0
print.printer_dru-muc-e017_(PCL).print_unwriteable_margin_left	0
print.printer_dru-muc-e017_(PCL).print_unwriteable_margin_right	0
print.printer_dru-muc-e017_(PCL).print_unwriteable_margin_top	0
print.printer_FreePDF.print_bgcolor	false
print.printer_FreePDF.print_bgimages	false
print.printer_FreePDF.print_colorspace	
print.printer_FreePDF.print_command	
print.printer_FreePDF.print_downloadfonts	false
print.printer_FreePDF.print_duplex	1515870810
print.printer_FreePDF.print_edge_bottom	0
print.printer_FreePDF.print_edge_left	0
print.printer_FreePDF.print_edge_right	0
print.printer_FreePDF.print_edge_top	0
print.printer_FreePDF.print_evenpages	true
print.printer_FreePDF.print_footercenter	
print.printer_FreePDF.print_footerleft	&PT
print.printer_FreePDF.print_footerright	&D
print.printer_FreePDF.print_headercenter	
print.printer_FreePDF.print_headerleft	&T
print.printer_FreePDF.print_headerright	&U
print.printer_FreePDF.print_in_color	true
print.printer_FreePDF.print_margin_bottom	0.5
print.printer_FreePDF.print_margin_left	0.5
print.printer_FreePDF.print_margin_right	0.5
print.printer_FreePDF.print_margin_top	0.5
print.printer_FreePDF.print_oddpages	true
print.printer_FreePDF.print_orientation	0
print.printer_FreePDF.print_page_delay	50
print.printer_FreePDF.print_paper_data	9
print.printer_FreePDF.print_paper_height	11,00
print.printer_FreePDF.print_paper_name	
print.printer_FreePDF.print_paper_size_type	0
print.printer_FreePDF.print_paper_size_unit	1
print.printer_FreePDF.print_paper_width	8,50
print.printer_FreePDF.print_plex_name	
print.printer_FreePDF.print_resolution	1515870810
print.printer_FreePDF.print_resolution_name	
print.printer_FreePDF.print_reversed	false
print.printer_FreePDF.print_scaling	1,00
print.printer_FreePDF.print_shrink_to_fit	true
print.printer_FreePDF.print_to_file	false
print.printer_FreePDF.print_unwriteable_margin_bottom	0
print.printer_FreePDF.print_unwriteable_margin_left	0
print.printer_FreePDF.print_unwriteable_margin_right	0
print.printer_FreePDF.print_unwriteable_margin_top	0
privacy.donottrackheader.enabled	true
security.disable_button.openCertManager	false
security.sandbox.content.tempDirSuffix	{8194379b-ecbc-42a1-b645-2027e68f26de}
storage.vacuum.last.index	1
storage.vacuum.last.places.sqlite	1504104702
user.js Preferences

Your profile folder contains a user.js file, which includes preferences that were not created by Daily.
Important Locked Preferences
Name 	Value
Places Database
Integrity 	Verify Integrity
JavaScript
Incremental GC 	true
Accessibility
Activated 	false
Prevent Accessibility 	0
Accessible Handler Used 	false
Accessibility Instantiator 	
Library Versions
	Expected minimum version	Version in use
NSPR	4.17 Beta	4.17 Beta
NSS	3.33 Beta	3.33 Beta
NSSSMIME	3.33 Beta	3.33 Beta
NSSSSL	3.33 Beta	3.33 Beta
NSSUTIL	3.33 Beta	3.33 Beta
Sandbox
Content Process Sandbox Level	0
Effective Content Process Sandbox Level	0
Component: Untriaged → Provider: CalDAV
Product: Thunderbird → Calendar
Do you get ayn error messages in Error Console?

I tried to use CalDAV with Lightning 5.9a1 (20170913031506) and got the following message:
> ReferenceError: assignment to undeclared variable compName    calDavCalendar.js:1847:17
https://dxr.mozilla.org/comm-central/source/calendar/providers/caldav/calDavCalendar.js#1847
Attached patch 1399483-calDavCalendar.patch (obsolete) — Splinter Review
'strict' is now used for modules, so this might have caused it.
Attachment #8908057 - Flags: review?(ssitter)
Yes, this matches my investigation. There is another reference error for variable webDavSync in calDavCalendar.js line 1514. Fixing both seems to fix CalDAV. Could you provde an updated patch?

When playing with Lightning more reference error were reported, like

ReferenceError: Services is not defined  datetimepickers.xml:1786:15
	initTimeFormat chrome://calendar/content/datetimepickers/datetimepickers.xml:1786:15
	datetimepicker-base_XBL_Constructor chrome://calendar/content/datetimepickers/datetimepickers.xml:1466:9
	editReminder chrome://calendar/content/calendar-dialog-utils.js:159:5
	commonUpdateReminder chrome://calendar/content/calendar-dialog-utils.js:428:13
	updateReminder chrome://lightning/content/lightning-item-iframe.js:1381:5
	oncommand chrome://lightning/content/lightning-item-iframe.xul:1:1

ReferenceError: Services is not defined  datetimepickers.xml:1878:15
	formatTime chrome://calendar/content/datetimepickers/datetimepickers.xml:1878:15
	update chrome://calendar/content/datetimepickers/datetimepickers.xml:591:33
	set_value chrome://calendar/content/datetimepickers/datetimepickers.xml:1469:1
	timepicker_XBL_Constructor chrome://calendar/content/datetimepickers/datetimepickers.xml:559:26
	editReminder chrome://calendar/content/calendar-dialog-utils.js:159:5
	commonUpdateReminder chrome://calendar/content/calendar-dialog-utils.js:428:13
	updateReminder chrome://lightning/content/lightning-item-iframe.js:1381:5
	oncommand chrome://lightning/content/lightning-item-iframe.xul:1:1

ReferenceError: document is not defined calUtils.js:1152:21
	applyAttributeToMenuChildren file:///.../calendar-js/calUtils.js:1152:21
	changeContextMenuForTask chrome://calendar/content/calendar-task-tree.js:61:5
	onpopupshowing chrome://messenger/content/messenger.xul:1:1

ReferenceError: document is not defined calUtils.js:304:9
	calRadioGroupSelectItem file:///.../calendar-js/calUtils.js:304:9
	onDatePick chrome://calendar/content/calendar-print-dialog.js:306:5
	onchange chrome://calendar/content/calendar-print-dialog.xul:1:1
	fireEvent chrome://calendar/content/datetimepickers/datetimepickers.xml:1494:11
	update chrome://calendar/content/datetimepickers/datetimepickers.xml:330:23
	clickDate chrome://calendar/content/datetimepickers/datetimepickers.xml:376:15
	fireEvent chrome://calendar/content/widgets/minimonth.xml:971:11
	onDayActivate chrome://calendar/content/widgets/minimonth.xml:1277:19
	onxblclick chrome://calendar/content/widgets/minimonth.xml:1371:1

TypeError: this.schangeMenuByPropertyName is not a function  calendar-menus.xml:23:38
	this.mPopupHandler chrome://calendar/content/calendar-menus.xml:23:38
Here you go. What are we going to do with the other failures? I'm using Daily and Calendar works, as far as I can see. But I didn't try everything.
Attachment #8908073 - Flags: review?(ssitter)
Comment on attachment 8908073 [details] [diff] [review]
1399483-calDavCalendar.patch (v2)

I guess we should file a new bug report for the other reference errors.
Attachment #8908073 - Flags: review?(ssitter) → review+
Attachment #8908057 - Attachment is obsolete: true
Attachment #8908057 - Flags: review?(ssitter)
Summary: caldav broken with latest thunderbird+lightning → caldav broken with latest thunderbird+lightning [ReferenceError: assignment to undeclared variable in calDavCalendar.js]
Attached patch 1399483-more-js-errors.patch (obsolete) — Splinter Review
Let's see whether this works for you.
Attachment #8908075 - Flags: review?(ssitter)
I cannot test the xml file changes because it seems impossible to open and modify chrome.jar on Windows. But based on code review it should be ok.

The changes in calutils.js have no impact, I now get ReferenceError: window is not defined instead. The error is reported when opening context menu for task entry in today pane and opening e.g. Progress sub-menu.
Comment on attachment 8908075 [details] [diff] [review]
1399483-more-js-errors.patch

OK, looks like I need to do this with more time in another bug.
Attachment #8908075 - Attachment is obsolete: true
Attachment #8908075 - Flags: review?(ssitter)
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/fbadefb10f45
add missing variable declarations in calDavCalendar.js. r=ssitter DONTBUILD
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → 5.9
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/68db819d0e77
fix some calendar JS errors (typo, missing import). r=ssitter
Damn, that got landed with the wrong bug number.
Downloaded latest builds. Same problem. Calendar pane is not opened clicking on the calendar symbol.
No menue entry for calendar, while calendar preferences are available via "Tools->Addon options->Lightning".
Please be more precise. Which latest builds? If you use matching builds, everything works.
You need to log in before you can comment on or make changes to this bug.