Closed Bug 1399486 Opened 4 years ago Closed 4 years ago

Downloads button auto-hide panel sometimes shows the wrong (checked) state when automatically toggling autohide off (so should be unchecked) as user moves an item

Categories

(Firefox :: Toolbars and Customization, defect, P1)

defect

Tracking

()

VERIFIED FIXED
Firefox 57
Iteration:
57.3 - Sep 19
Tracking Status
firefox57 --- verified

People

(Reporter: Gijs, Assigned: Gijs)

References

Details

(Whiteboard: [reserve-photon-structure])

Attachments

(1 file)

STR:

1. open customize mode
2. click downloads button, enable autohide if not enabled
3. move downloads button to the right (for instance)

ER:
the checkbox in the panel should be unticked

AR:
the checkbox is sometimes ticked

(this is a race condition, so you may need to try several times to reproduce)

Optional step 4: click downloads button again to hide the panel and then again to show it, and the tickbox state will be correct.
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Flags: qe-verify+
Priority: -- → P1
QA Contact: gwimberly
Whiteboard: [reserve-photon-structure]
Iteration: --- → 57.3 - Sep 19
Comment on attachment 8909133 [details]
Bug 1399486 - show downloads auto hide panel after changing the pref instead of before,

https://reviewboard.mozilla.org/r/180714/#review185962
Attachment #8909133 - Flags: review?(mak77) → review+
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/ab576fa6f896
show downloads auto hide panel after changing the pref instead of before, r=mak
https://hg.mozilla.org/mozilla-central/rev/ab576fa6f896
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 57
I have reproduced the issue mentioned in comment 0 using an affected Firefox 57.0a1 build (BuildId:20170913220255).

I have verified that the issue is not reproducible using Firefox 57.0b7 (Build Id:20171009192146) on Windows 10 64bit, macOS 10.11.6 and Ubuntu 16.04 64bit.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.