containers list scrolling

RESOLVED WORKSFORME

Status

()

Firefox
Tabbed Browser
P4
normal
RESOLVED WORKSFORME
a month ago
13 days ago

People

(Reporter: tech, Unassigned)

Tracking

57 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a month ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20170810100255

Steps to reproduce:

Add enough custom containers to your inital list until overflowing your display vertically.



Actual results:

except you get a very long list of containers you should notice there is not scroll bar to go down to bottom containers (not visible).


Expected results:

Give a scroll bar to allow us to go down.
Not a priority bug because:
- I don't think there are lot of people who have as much containers 
- It is possible to scroll from the arrows keys of the keyboard
(Reporter)

Comment 1

a month ago
Also it could be very nice to have an option to sort all containers or even dynamicaly change position of each one by a drag on drop on the configuration page.
For now, I made a script to sort containers alphabetically from the json file in profile folder but it is not realy ideal.
Just for your information, the very trivial script is :

```
function sortByKey(array, key) {
return array.sort(function(a, b) {
  if (!b[key]) {
    return -1;
  } else if (!a[key]) {
    return 1;
  } else {
    return a[key].localeCompare(b[key]); 
  }});
}

containers = require('/home/user/.mozilla/firefox/xxxx.default/containers.json');
//console.log(containers);
containers.identities = sortByKey(containers.identities, 'name');
console.log(JSON.stringify(containers));
```

Regards

Comment 2

a month ago
Could you please provide (attach) a minimal, self-contained testcase?
Flags: needinfo?(tech)
(Reporter)

Comment 3

a month ago
honestly, I am not sure to understand what you ask.

Here is a screenshot when I click on "containers" icon (so I am at top of the list)
https://framapic.org/EbwsY8STSc5G/V3WcyNjjjMpR.png

Here is a screenshot when I go down at the bottom of the containers list (via arrows keys because there is no scroll bar to do that and it is the object of this issue)
https://framapic.org/lygGlmJjHT1B/FxtOhyaw1CKl.png

Please if you need anything other, tell me but give me explictely what you need.
This issue seems very simple so I thought you did not need screenshot but may be my explanation was bad ..
Flags: needinfo?(tech)

Updated

a month ago
Component: Untriaged → Tabbed Browser

Updated

a month ago
Priority: -- → P4
(Reporter)

Updated

13 days ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 days ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 4

13 days ago
Hi, 
I resolved this issue because all is covered by the new available addon :
https://addons.mozilla.org/en-US/firefox/addon/multi-account-containers/
I see it in the following news : https://blog.mozilla.org/tanvi/2017/10/03/update-firefox-containers/
Thanks for your work.
You need to log in before you can comment on or make changes to this bug.