Title bar is not visible in High Contrast mode on Ubuntu

RESOLVED INVALID

Status

()

Core
Widget: Gtk
--
major
RESOLVED INVALID
7 months ago
7 months ago

People

(Reporter: roxana.leitan@softvision.ro, Unassigned)

Tracking

55 Branch
Unspecified
Linux
Points:
---

Firefox Tracking Flags

(firefox55 affected, firefox56 affected, firefox57 affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 months ago
Created attachment 8907618 [details]
high contrast .png

Mozilla/5.0 (X11; Linux x86_64; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID:20170912220343

[Affected versions]:
Nightly 57.0a1, FF Release 55.0
 
[Affected platforms]:
Ubuntu 16.04 x64

[Steps to reproduce]:
1.Enable High Contrast theme from Universal Access
2.Launch Firefox

[Expected result]:
FF should be properly displayed

[Actual result]:
Title bar is not visible
(Reporter)

Updated

7 months ago
status-firefox55: --- → affected
status-firefox56: --- → affected
status-firefox57: --- → affected

Comment 1

7 months ago
Which gnome theme is this, and do other applications do the same thing?

My understanding is that the title bar on linux is still rendered by gtk / the window manager, and so if the title bar isn't readable I would assume that's an issue with the window manager / gtk / the OS theme in use - not with Firefox. Karl, is that right?
Component: Disability Access → Widget: Gtk
Flags: needinfo?(roxana.leitan)
Flags: needinfo?(karlt)
Product: Firefox → Core
Yes, the titlebar is rendered by Gtk by default and AFAIK Firefox does not interfere here. Looks like a bug in the theme. Can you check gnome-terminal and how does it render the titlebar?
(Reporter)

Comment 3

7 months ago
Yes, it's the same for gnome-terminal. The titlebar is not visible.
Flags: needinfo?(roxana.leitan)

Comment 4

7 months ago
(In reply to roxana.leitan@softvision.ro from comment #3)
> Yes, it's the same for gnome-terminal. The titlebar is not visible.

OK, then this isn't a Firefox issue. You may want to file an issue against the gnome theme you're using in the distro's tracker.
Status: NEW → RESOLVED
Last Resolved: 7 months ago
Flags: needinfo?(karlt)
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.