Weird behavior when filling a form.

RESOLVED DUPLICATE of bug 53318

Status

()

Core
Layout: Form Controls
--
major
RESOLVED DUPLICATE of bug 53318
16 years ago
16 years ago

People

(Reporter: Dan Naumov, Assigned: rods (gone))

Tracking

Trunk
x86
FreeBSD
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:0.9.9+) Gecko/20020425
BuildID:    2002042507

1) Clicking on a part of the submit form where you can change one of the
multiple options (Component, Platform, OS or Reproducibility) brings up the
select box, however, it's noticably offset from the position it's supposed to be at.

2) Sometimes, the select box comes up, but dissapears as soon as you let off the
left mouse button. The select box is supposed to stay up until you click elsewhere.

Reproducible: Always
Steps to Reproduce:
1. Go to http://www.mozilla.org/quality/help/bugzilla-helper.html
2. Left-Click on any of the select boxes (Component, Platform, OS or
Reproducibility).
(Reporter)

Comment 1

16 years ago
Created attachment 80907 [details]
A screenshot showing the select box being wildly offset.
Did you close the sidebar after loading the page by any chance?  Also, are you
using XBL form controls?

Comment 3

16 years ago
reassigning.
Assignee: morse → rods
Component: Form Manager → HTML Form Controls
(Reporter)

Comment 4

16 years ago
>Did you close the sidebar after loading the page by any chance?
I think I did.

Apparently, if I start Mozilla with the Sidebar disabled from View / SHow/Hide /
Sidebar, the problem does not occur. However, if I go to that helper form
webpage, open and close the sidebar several times, the problem starts occuring
again. Right now, I can reproduce it when I have the Sidebar open, but not when
it's closed.

>Also, are you using XBL form controls?
How do I find out ?
>>Also, are you using XBL form controls?
>How do I find out ?

It's an option in debug preferences....

But if you've been opening/closing the sidebar, this is a duplucate of
"[LNX]Drop down boxes (<select>) not rendered correctly after sidebar resize"

*** This bug has been marked as a duplicate of 53318 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.