Closed Bug 1399584 Opened 2 years ago Closed 2 years ago

Update context menu icons on back/forward buttons to match Photon style

Categories

(Firefox :: Theme, defect, P1)

All
Unspecified
defect

Tracking

()

VERIFIED FIXED
Firefox 58
Tracking Status
firefox57 --- verified
firefox58 --- verified

People

(Reporter: gustavo.silva, Assigned: dao)

References

(Blocks 1 open bug)

Details

(Whiteboard: [reserve-photon-visual])

Attachments

(2 files)

When right-clicking the back/forward buttons in Firefox, the icons used in the context menu haven't been updated to match the new Photon visual style.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P4
Whiteboard: [reserve-photon-visual]
Flags: qe-verify+
QA Contact: ovidiu.boca
Assignee: nobody → dao+bmo
Status: NEW → ASSIGNED
Priority: P4 → P1
Iteration: --- → 57.3 - Sep 19
Comment on attachment 8910215 [details]
Bug 1399584 - Update Back/Forward context menu icons.

https://reviewboard.mozilla.org/r/181706/#review187496

I didnt realise could right click on the back / forward arrows, looks great, cheers
Attachment #8910215 - Flags: review?(dharvey) → review+
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/44d4581ca826
Update Back/Forward context menu icons. r=daleharvey
Iteration: 57.3 - Sep 19 → ---
https://hg.mozilla.org/mozilla-central/rev/44d4581ca826
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 58
Comment on attachment 8910215 [details]
Bug 1399584 - Update Back/Forward context menu icons.

Approval Request Comment
[Feature/Bug causing the regression]: photon-visual polish
[User impact if declined]: Back/Forward context menu uses legacy icons
[Is this code covered by automated tests?]: no
[Has the fix been verified in Nightly?]: not yet
[Needs manual test from QE? If yes, steps to reproduce]:
[List of other uplifts needed for the feature/fix]: /
[Is the change risky?]: no
[Why is the change risky/not risky?]: simple isolated fix
[String changes made/needed]: /
Attachment #8910215 - Flags: approval-mozilla-beta?
Comment on attachment 8910215 [details]
Bug 1399584 - Update Back/Forward context menu icons.

p1 bug to polish photon, taking it!
Should be in 57b3
Attachment #8910215 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Tested on Linux 16.04 x 64, Mac OSX 10.12.5 and Windows 10 x 64 Latest Nightly 58.0a1
Build ID 20170925100307. Now, the cContext menu icons are updated to match new Photon style. Verified - Fixed. Thank you
Status: RESOLVED → VERIFIED
Flags: qe-verify+
Let's make sure this works as intended on Beta 57 as well.
Flags: qe-verify+
Verified fixed in Beta 57.0b9 on Windows 10 x64, macOS 10.13.1 and Ubuntu 16.04 x64.
Flags: qe-verify+
Duplicate of this bug: 622052
You need to log in before you can comment on or make changes to this bug.