Migrate calendar items from Lighthing(Windows) to Lightning(Linux), using *.ical-files

UNCONFIRMED
Unassigned

Status

Calendar
Import and Export
UNCONFIRMED
4 months ago
4 months ago

People

(Reporter: Andreas Aßmann, Unassigned)

Tracking

Lightning 5.4.3

Details

(Reporter)

Description

4 months ago
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:55.0) Gecko/20100101 Firefox/55.0
Build ID: 20170824053622

Steps to reproduce:

In Thunderbird-Lightning(Windows7) I exported my calendar-dates into an *.ical-file and then tried to import them into Thunderbird-Lightning(Linux).


Actual results:

But it did not work, and I got the following error-message:

””””””
307 items failed to import. The last error was: [Exception... "Component returned failure code: 0x8000ffff (NS_ERROR_UNEXPECTED) [mozIStorageConnection.rollbackTransaction]"  nsresult: "0x8000ffff (NS_ERROR_UNEXPECTED)"  location: "JS frame :: file:///home/andreas.assmann/.thunderbird/fvnas666.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calStorageCalendar.js :: calStorageCalendar.prototype.releaseTransaction :: line 2323"  data: no]
””””””

And not only this; it was not even possible to create new calendar dates in Lightning(Linux).

At this moment I run the following machines/systems:
- Windows-7 64bit (my main system), completely updated, together with
- Windows-10 64bit, completely updated, in a dual boot system,
and
- Fedora-26 LXDE 32bit, completely updated, on a second machine (Linux Kernel 4.12.11-300; Thunderbird 52.3.0-1).

I tried to get help from Fedora (laptop@lists.fedoraproject.org and users@lists.fedoraproject.org) but did not get any answer by now. Which made me think that the above issue is probably a bug.

By the way, importing *.ical-calendar-dates into Thunderbird-Lightning-Windows10 worked without any problem.

Anyway, thanks in advance for your help and for any helpful information.

Greetings 


Expected results:

complete migration of all calendar-dates from Thunderbird-Lightning-Windows-7 to Thunderbird-Lightning-LinuxFedora-26

Comment 1

4 months ago
Maybe an encoding issue? Could you attach a .ical file here, see "Attach File" above. BTW, what's .ical? I know .ics. You could export from Windows and Linux and see that differs.
Component: Migration → Import and Export
Product: Thunderbird → Calendar
Version: 52 Branch → Lightning 5.4.3
(Reporter)

Comment 2

4 months ago
Please accept my excuses. I meant .ics and wrote .ical by error. Of course, I exported .ics-files from Windows-7 and tried to import them to Linux-Fedora and that didn't work. As I said, I could import these .ics-file into Windows-10 without problem

Comment 3

4 months ago
Repeating:
Export on Windows and on Linux and compare the files. Also, attach some files that fail to import to the bug after removing personal information. The format should be the same, so perhaps there's an encoding issue.

Comment 4

4 months ago
I mean, I understand you want to import *into* Linux, but just create a dummy event in Linux and export it for comparison.

Comment 5

4 months ago
Does it work if you directly open the ics file and therefore skip the database component that reports the error? Use menu File > Open > Calendar File to integrate the ics file as a new calendar in Lightning. If this works the problem is probably not within the file but within the database component.
(Reporter)

Comment 6

4 months ago
Answering to Jorg K:
I cannot create a new event nor an .ics-file under Lightning-Linux-Fedora. When I open a new event there and then click on "Save and close", nothing happens, the new event remains open, and when I close it, no new event has been created in Lightning.

Answering to Stefan Sitter:
I created a "dummy"-.ics-file under WINDOWS-10 and then imported it into Lightning-Linux-Fedora the way you told me (File > Open > Calendar File). It worked without any problem and the newly imported event is plain to see!
You need to log in before you can comment on or make changes to this bug.