Focus does not leave location bar (URI field) on first click

RESOLVED DUPLICATE of bug 66834

Status

SeaMonkey
General
RESOLVED DUPLICATE of bug 66834
16 years ago
13 years ago

People

(Reporter: Andreas, Assigned: Matti)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.0rc1) Gecko/20020417
BuildID:    2002041711

When focus is on the location field, it takes at least two clicks to focus the
document area. This is contrary to common usage, user's expectation and it is
also annoying and should be changed.

Somehow this happens when you are not aware that the current focus was on the
location field and the location list will pop down.

Reproducible: Always
Steps to Reproduce:
1. Focus the location (URI) field.
2. Try to focus the document area. You will have to click more than once.


Actual Results:  Focus only changes after a second click.

Expected Results:  Focus should change on first click.

Comment 1

16 years ago
WFM with Mozilla/5.0 (Windows; U; Win98; de-AT; rv:1.0rc1) Gecko/20020417

My test:
- set cursor into RTL-Edit-Window between "6" and "0", c
  => cursor is flickering there
- right mouseclick into first word of your report "From" between "F" and "r"
  => cursor disappears in URL-Window
- keys <sift>+<cursor-down>
  => Text will be marked starting wiht "r"

meaning of signs:
=> result or reaction as expected
!! unexpected result or reaction
-- noticed result or reaction

You see, for me nothing was unexpected
(Reporter)

Comment 2

16 years ago
I think I didn't explain correctly: As I said this happens when you are not
aware the focus is on the RTL-Edit-Window. In that case, if you scroll using the
arrow keys (usually you will be scrolling down in most cases, won't you ;-), the
address list pops down. Then, when you realize your fault and click in the
document window you have to click twice - this is what is unexpected to me.
Sorry for the vague explanation at first go.

Regards

Andreas

Comment 3

16 years ago

*** This bug has been marked as a duplicate of 66834 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.