mac updater does not set permissions properly for multi-user use

RESOLVED DUPLICATE of bug 1337007

Status

()

P2
normal
RESOLVED DUPLICATE of bug 1337007
a year ago
7 months ago

People

(Reporter: long, Unassigned)

Tracking

55 Branch
x86_64
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
I had version 54.x installed and it worked properly for multi-user use.  The file permissions it had are listed in the attached firefox.txt.  I then let Firefox update itself to 55.0.3 and the resulting permissions prevented other users on the system from being able to run Firefox.  The permissions from the post-upgrade are in the attached firefox2.txt.  This is a continuation of bug 836760.
(Reporter)

Comment 1

a year ago
Can't figure out how to add attachments so I'll just paste in the relevant firefox permissions problem.

Before upgrade:

-rwxr-xr-x@  1 long  admin     24224 Jul  3 13:00 firefox


After update:

-rwx-w----@  1 long  admin     24224 Sep 13 15:39 firefox
Reporter: Can you please provide which version of MacOS you are running? Thanks.
Flags: needinfo?(long)
(Reporter)

Comment 3

a year ago
Well the drive on that Mac died a nasty death before I could respond.  The OS version should have been 10.12.6 as I do keep it up to date but I don't think I have a way to fully verify that now.
Flags: needinfo?(long)
(Reporter)

Comment 4

a year ago
Never mind, I dug up some HTTP logs that confirm I have been using 10.12.6.

Updated

11 months ago
Component: Installer → Application Update
Product: Firefox → Toolkit

Updated

8 months ago
Priority: -- → P2
Are you still able to reproduce this when updating from Firefox 55 or above to a newer version?
Flags: needinfo?(long)
(Reporter)

Comment 6

7 months ago
I let it update from 58.0.1 to 58.0.2 tonight and it appears that the proper file permissions were maintained.
Flags: needinfo?(long)
Bug 1337007 was fixed in Firefox 55 and the fix would only be seen when updating from Firefox 55 to a newer version. Quite certain that bug 1337007 fixed this.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1337007
You need to log in before you can comment on or make changes to this bug.