Closed Bug 1399647 Opened 2 years ago Closed 2 years ago

Go button arrow is scaled down (wrong size)

Categories

(Firefox :: Theme, defect, P1)

57 Branch
defect

Tracking

()

VERIFIED FIXED
Firefox 58
Tracking Status
firefox57 --- verified
firefox58 --- verified

People

(Reporter: abenson, Assigned: dao)

References

(Blocks 1 open bug)

Details

(Whiteboard: [reserve-photon-visual])

Attachments

(2 files)

The Go button icon (forward.svg) is scaled down from the original icon size and it should not be. 

The hover state also has a margin on the top and bottom. It should fill the entire space of the URL bar behind it.
Whiteboard: [photon-visual] → [photon-visual] [triage]
Flags: qe-verify?
Priority: -- → P3
Whiteboard: [photon-visual] [triage] → [reserve-photon-visual]
Can reproduce this on nightly but not on inbound, may have been fixed
Assignee: nobody → dharvey
Status: NEW → ASSIGNED
Flags: qe-verify? → qe-verify+
Priority: P3 → P1
Iteration: --- → 57.3 - Sep 19
QA Contact: ovidiu.boca
Yup, I could reproduce this in an old nightly but fixed in latest nightly + inbound
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → WORKSFORME
Tested on Mac OS X 10.10, Windows 10 and Ubuntu 16.04 with FF Nightly 57.0a1(2017-09-20) and I can't reproduce it.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
It's still scaled down though.
Status: VERIFIED → REOPENED
Resolution: WORKSFORME → ---
Summary: Go button arrow is scaled down (wrong size) and the hover state isn't filling the entire background → Go button arrow is scaled down (wrong size)
Assignee: dharvey → dao+bmo
Flags: qe-verify+
Status: REOPENED → ASSIGNED
Iteration: 57.3 - Sep 19 → ---
I'll also use forward.svg instead of back.svg as that seems to make more sense.
Comment on attachment 8910707 [details]
Bug 1399647 - Stop scaling down the Go button's icon.

https://reviewboard.mozilla.org/r/182168/#review187672

Seems a strange choice to have used the back button in the first place here so this all looks good to me
Attachment #8910707 - Flags: review?(dharvey) → review+
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/953afb698050
Stop scaling down the Go button's icon. r=daleharvey
https://hg.mozilla.org/mozilla-central/rev/953afb698050
Status: ASSIGNED → RESOLVED
Closed: 2 years ago2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 58
Comment on attachment 8910707 [details]
Bug 1399647 - Stop scaling down the Go button's icon.

Approval Request Comment
[Feature/Bug causing the regression]: photon-visual polish
[User impact if declined]: Go icon is too small
[Is this code covered by automated tests?]: no
[Has the fix been verified in Nightly?]: not yet
[Needs manual test from QE? If yes, steps to reproduce]:
[List of other uplifts needed for the feature/fix]: /
[Is the change risky?]: no
[Why is the change risky/not risky?]: trivial isolated fix
[String changes made/needed]: /
Attachment #8910707 - Flags: approval-mozilla-beta?
Comment on attachment 8910707 [details]
Bug 1399647 - Stop scaling down the Go button's icon.

p1 bug to polish photon, taking it!
Should be in 57b3
Attachment #8910707 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
I verified this issue using Nightly 58.0a1 and Firefox 57.0b4 on Windows 10 x64, Ubuntu 16.04, Mac OS X 10.12, and Windows 7 x64.
I will mark this as verified fixed.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.