Update Developer Edition, DevTools and Roadshow tiles on /Developer/

RESOLVED FIXED

Status

www.mozilla.org
Pages & Content
RESOLVED FIXED
7 months ago
6 months ago

People

(Reporter: Maciej Pluta, Assigned: kohei)

Tracking

Production

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

7 months ago
Team,

We'd like to change the link for Firefox DevTools tile on this page:
https://www.mozilla.org/en-US/developer/

from: 
https://www.mozilla.org/en-US/firefox/developer/
To:
https://developer.mozilla.org/en-US/docs/Tools
(Reporter)

Updated

7 months ago
Flags: needinfo?(erenaud)

Updated

7 months ago
Blocks: 1399666
(Assignee)

Updated

6 months ago
No longer blocks: 1399666
Duplicate of this bug: 1399666
(Assignee)

Comment 2

6 months ago
From Bug 1399666:

> We'd like to change the Developer Roadshow link on this page:
> https://www.mozilla.org/en-US/developer/
> 
> From:
> https://hacks.mozilla.org/2017/02/devroadshow/?utm_source=www.mozilla.org&utm_medium=referral&utm_campaign=developer-hub
> 
> To:
> https://github.com/mozilla/devroadshow2017
Assignee: nobody → kohei.yoshino
Status: NEW → ASSIGNED
Flags: needinfo?(erenaud)
Summary: /Developer Firefox DevTools Tile - Link Change → Update Firefox DevTools and Developer Roadshow tile links on /Developer/
(Assignee)

Comment 3

6 months ago
Actually this page has 2 DevTools tiles now. I think one of them, maybe the top one, should rather say Firefox Developer Edition while keeping the /firefox/developer/ link. The second one should be linked to https://developer.mozilla.org/docs/Tools

Thoughts?
Flags: needinfo?(mpluta)
(Assignee)

Comment 4

6 months ago
Ah, Bug 1399663 has already a request for that.
Flags: needinfo?(mpluta)
(Assignee)

Updated

6 months ago
Duplicate of this bug: 1399663
(Assignee)

Updated

6 months ago
Summary: Update Firefox DevTools and Developer Roadshow tile links on /Developer/ → Update Developer Edition, DevTools and Roadshow tiles on /Developer/
(Assignee)

Comment 7

6 months ago
At the best guess I've changed the CTA link labels as follows. Is it okay for you?

DevEdition hero: "Download Developer Edition"
DevTools tile: "Explore DevTools" (replaces "Learn more" with current hero's copy)
Flags: needinfo?(mpluta)
(Reporter)

Updated

6 months ago
Flags: needinfo?(mpluta) → needinfo?(alainez)
(Assignee)

Comment 8

6 months ago
One more thing: Firefox DevTools tile has the old Developer Edition logo. Can we have a new image?

Comment 9

6 months ago
Hi Kohei

"Explore DevTools", should read: "Explore devtools". 

Reason is that DevTools is the name of the Firefox team that makes developer tools. In this case we're asking the reader to learn about Firefox developer tools. 

Here is a link to the Photon identity assets: http://design.firefox.com/photon/visuals/product-identity-assets.html
Flags: needinfo?(alainez)
(Assignee)

Comment 10

6 months ago
AFAIK DevTools is widely used rather than devtools.

https://www.mozilla.org/en-US/firefox/developer/
https://developer.mozilla.org/en-US/docs/Tools
https://hacks.mozilla.org/category/developer-tools/
https://twitter.com/FirefoxDevTools
http://devtoolschallenger.com/

This is the image with the old logo, that can be found in the second DevTools tile on 
https://www.mozilla.org/en-US/developer/ :

https://www.mozilla.org/media/img/mozorg/developer/hub/resource-devtools.68bb796fbf46.jpg

I'm happy to update it if the source Photoshop or Illustrator asset is available.
(Assignee)

Comment 11

6 months ago
ni :craigcook who built the page in Bug 1336570.
Flags: needinfo?(craigcook.bugz)
(In reply to Kohei Yoshino [:kohei] from comment #10)

> This is the image with the old logo, that can be found in the second
> DevTools tile on 
> https://www.mozilla.org/en-US/developer/ :
> 
> https://www.mozilla.org/media/img/mozorg/developer/hub/resource-devtools.
> 68bb796fbf46.jpg
> 
> I'm happy to update it if the source Photoshop or Illustrator asset is
> available.

This was created by Lee Tom and unfortunately I don't have a layered file. We'll need to make a new image from scratch with the new logo. I can have something for you soon unless you want to take a stab at it.
Flags: needinfo?(craigcook.bugz)
(Assignee)

Comment 13

6 months ago
Okay, I'll create a new one with brand-new Photoshop CC 2018.

Comment 14

6 months ago
Commits pushed to master at https://github.com/mozilla/bedrock

https://github.com/mozilla/bedrock/commit/239a9d73102d906a7ce9c0a07ea982e79f2a9130
Fix Bug 1399665 - Update Developer Edition, DevTools and Roadshow tiles on /Developer/

https://github.com/mozilla/bedrock/commit/92e97f54ce64c071f747f0dd8692add34d778e29
Merge pull request #5222 from kyoshino/bug-1399665-developer-tiles

Fix Bug 1399665 - Update Developer Edition, DevTools and Roadshow tiles on /Developer/

Updated

6 months ago
Status: ASSIGNED → RESOLVED
Last Resolved: 6 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.