Closed Bug 139969 Opened 19 years ago Closed 19 years ago

Caret doesn't show in text form field

Categories

(Core :: Layout: Text and Fonts, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 105397

People

(Reporter: hanan_cohen, Assigned: mkaply)

References

()

Details

When direction is set to RTL 
and language set as Hebrew
and nothing was typed
the caret is not showm.

The caret seems to be "hidden" behind the frame of the text field.
It looks as if the caret is drawn just one or two pixels too far to the right.
Status: UNCONFIRMED → NEW
Ever confirmed: true
*** Bug 142808 has been marked as a duplicate of this bug. ***
Additional Comments from the duplicate bug report:

When the cursor is set at the beginning of a line, only it's upper dot is showing. 

Note: the description of this bug is incorrect ("and nothing was typed"), the
actual prerequisite for the bug is that the cursor should be at "the beginning
of a line"

The vertical line is hidden outside the right border of the textarea.
This also happens with other Hebrew websites (both Logical Hebrew and Visual Hebrew)

Reproducible: Always
Steps to Reproduce:
1. Visit http://www.mentor.org.il/mb/mentor/post.shtml
2. Focus the cursor on the main textarea (it will set correctly to the beginning
of the line)

Actual Results:  Only the upper dot will show.

Expected Results:  The Whole cursor should be visible, even if the cursor is set
at the beginning of the line.

If you enter any text character, the cursor will show completely.

Verified under Win2k (v1.0RC1-2002041711) and MacOS9.2 (v0.99-2002031106)
I am almost certain that this prooblem also happens with the BeOS and Linux
versions of Mozilla. I can test it if there is a need.

Please change both Platform and OS to "ALL".
OS: Windows 2000 → All
Hardware: PC → All
Another starange thing on osx which might be related: when typing Hebew, the
second character displays ideticle to the first, until a third character is typed.
related/dup: bug 105397
Agreed.

*** This bug has been marked as a duplicate of 105397 ***
Status: NEW → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
Component: Layout: BiDi Hebrew & Arabic → Layout: Text
QA Contact: zach → layout.fonts-and-text
You need to log in before you can comment on or make changes to this bug.