Closed Bug 1399693 Opened 3 years ago Closed 3 years ago

Update the watermark Firefox logo used on new tab from png to svg

Categories

(Firefox :: New Tab Page, defect, P1)

57 Branch
defect

Tracking

()

VERIFIED FIXED
Firefox 57
Tracking Status
firefox57 --- verified

People

(Reporter: abenson, Assigned: Fischer)

References

Details

(Whiteboard: [photon-onboarding][photon-onboarding-newui])

Attachments

(2 files)

Attached image newtab-firefox-gray.svg
Update the watermark icon used on new tab from png to svg [attached].
Whiteboard: [photon-onboarding] [photon-onboarding-newui] → [photon-onboarding][photon-onboarding-newui][triage]
Flags: qe-verify+
Priority: -- → P1
Whiteboard: [photon-onboarding][photon-onboarding-newui][triage] → [photon-onboarding][photon-onboarding-newui]
Assignee: nobody → fliu
Status: NEW → ASSIGNED
Comment on attachment 8908487 [details]
Bug 1399693 - Update the watermark Firefox logo used on new tab from png to svg,

https://reviewboard.mozilla.org/r/180154/#review185296

please make sure run the svg optimizer on the image before merging
Attachment #8908487 - Flags: review?(gasolin) → review+
Keywords: checkin-needed
Blocks: 1392475
NI myself to remind myself this bug needs uplift to Beta after verified on Nightly.
Flags: needinfo?(fliu)
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/1a429aa9abdb
Update the watermark Firefox logo used on new tab from png to svg, r=gasolin
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/1a429aa9abdb
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 57
I have verified that the watermark has been updated to svg.
Status: RESOLVED → VERIFIED
Comment on attachment 8908487 [details]
Bug 1399693 - Update the watermark Firefox logo used on new tab from png to svg,

Approval Request Comment
[Feature/Bug causing the regression]:
Bug 1392475

[User impact if declined]: 
User may see a blur firefox watermark

[Is this code covered by automated tests?]: 
No since it is only about updating image

[Has the fix been verified in Nightly?]: 
Yes

[Needs manual test from QE? If yes, steps to reproduce]: 
1. Open about:newtab
2. Click the firefox icon button on the top-left corner to open the onboarding tour overlay
3. Click "Skip Tour" button on the bottom-left corner on the onboarding tour overlay
4. Observe a clear firefox watermark icon button on the top-left corner on about:newtab

[List of other uplifts needed for the feature/fix]:
N/A

[Is the change risky?]:
No just update image

[Why is the change risky/not risky?]:
Just update image

[String changes made/needed]:
N/A
Flags: needinfo?(fliu)
Attachment #8908487 - Flags: approval-mozilla-beta?
Comment on attachment 8908487 [details]
Bug 1399693 - Update the watermark Firefox logo used on new tab from png to svg,

It already in m-b.
Attachment #8908487 - Flags: approval-mozilla-beta? → approval-mozilla-beta-
I can confirm the gray logo is a .svg format, I verified using Developer Tools on Fx 57.0b8, on Windows 10 x64.
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.