Closed Bug 1399773 (android-139) Opened 2 years ago Closed 2 years ago

Intermittent Android xpcshell xpcshell return code: 139 in random test

Categories

(Firefox for Android :: Testing, defect, P3, major)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1389805

People

(Reporter: aryx, Assigned: gbrown)

References

Details

(Keywords: intermittent-failure)

This happens quite frequently.

E.g. https://treeherder.mozilla.org/logviewer.html#?job_id=130931106&repo=autoland

Missing symbols is bug 1389805.

More bugs: https://bugzilla.mozilla.org/buglist.cgi?list_id=13778278&chfield=[Bug%20creation]&chfieldfrom=90d&short_desc_type=allwordssubstr&short_desc=xpcshell%20return%20code%3A%20139&chfieldto=Now&query_format=advanced

[task 2017-09-14T06:05:19.010498Z] 06:05:19  WARNING -  TEST-UNEXPECTED-FAIL | intl/uconv/tests/unit/test_decode_CP1258.js | xpcshell return code: 139
[task 2017-09-14T06:05:19.010884Z] 06:05:19     INFO -  TEST-INFO took 4211ms
[task 2017-09-14T06:05:19.011128Z] 06:05:19     INFO -  >>>>>>>
[task 2017-09-14T06:05:19.015239Z] 06:05:19     INFO -  intl/uconv/tests/unit/test_decode_CP1258.js | xpcw: cd /mnt/sdcard/tests/xpc/intl/uconv/tests/unit
[task 2017-09-14T06:05:19.015440Z] 06:05:19     INFO -  intl/uconv/tests/unit/test_decode_CP1258.js | xpcw: xpcshell -r /mnt/sdcard/tests/xpc/c/httpd.manifest --greomni /data/local/xpcb/target.apk -m -s -e const _HEAD_JS_PATH = "/mnt/sdcard/tests/xpc/head.js"; -e const _MOZINFO_JS_PATH = "/mnt/sdcard/tests/xpc/p/mozinfo.json"; -e const _TESTING_MODULES_DIR = "/mnt/sdcard/tests/xpc/m"; -f /mnt/sdcard/tests/xpc/head.js -e const _SERVER_ADDR = "localhost" -e const _HEAD_FILES = []; -e const _JSDEBUGGER_PORT = 0; -e const _TEST_FILE = ["test_decode_CP1258.js"]; -e const _TEST_NAME = "intl/uconv/tests/unit/test_decode_CP1258.js" -e _execute_test(); quit(0);
[task 2017-09-14T06:05:19.015499Z] 06:05:19     INFO -  (xpcshell/head.js) | test MAIN run_test pending (1)
[task 2017-09-14T06:05:19.015561Z] 06:05:19     INFO -  intl/uconv/tests/unit/test_decode_CP1258.js | testing decoding from windows-1258 to Unicode.
[task 2017-09-14T06:05:19.015706Z] 06:05:19     INFO -  TEST-PASS | intl/uconv/tests/unit/test_decode_CP1258.js | checkDecode - [checkDecode : 39] " !\\"#$%&'()*+,-./0123456789:;<=>?@ABCDEFGHIJKLMNOPQRSTUVWXYZ[\\\\]^_`abcdefghijklmnopqrstuvwxyz{|}~€\x81‚ƒ„…†‡ˆ‰\x8A‹Œ\x8D\x8E\x8F\x90‘’“”•–—˜™\x9A›œ\x9D == " !\\"#$%&'()*+,-./0123456789:;<=>?@ABCDEFGHIJKLMNOPQRSTUVWXYZ[\\\\]^_`abcdefghijklmnopqrstuvwxyz{|}~€\x81‚ƒ„…†‡ˆ‰\x8A‹Œ\x8D\x8E\x8F\x90‘’“”•–—˜™\x9A›œ\x9D
[task 2017-09-14T06:05:19.015772Z] 06:05:19     INFO -  intl/uconv/tests/unit/test_decode_CP1258.js | testing decoding from x-cp1258 to Unicode.
[task 2017-09-14T06:05:19.015972Z] 06:05:19     INFO -  TEST-PASS | intl/uconv/tests/unit/test_decode_CP1258.js | checkDecode - [checkDecode : 39] " !\\"#$%&'()*+,-./0123456789:;<=>?@ABCDEFGHIJKLMNOPQRSTUVWXYZ[\\\\]^_`abcdefghijklmnopqrstuvwxyz{|}~€\x81‚ƒ„…†‡ˆ‰\x8A‹Œ\x8D\x8E\x8F\x90‘’“”•–—˜™\x9A›œ\x9D == " !\\"#$%&'()*+,-./0123456789:;<=>?@ABCDEFGHIJKLMNOPQRSTUVWXYZ[\\\\]^_`abcdefghijklmnopqrstuvwxyz{|}~€\x81‚ƒ„…†‡ˆ‰\x8A‹Œ\x8D\x8E\x8F\x90‘’“”•–—˜™\x9A›œ\x9D
[task 2017-09-14T06:05:19.016049Z] 06:05:19     INFO -  intl/uconv/tests/unit/test_decode_CP1258.js | testing decoding from cp1258 to Unicode.
[task 2017-09-14T06:05:19.016248Z] 06:05:19     INFO -  TEST-PASS | intl/uconv/tests/unit/test_decode_CP1258.js | checkDecode - [checkDecode : 39] " !\\"#$%&'()*+,-./0123456789:;<=>?@ABCDEFGHIJKLMNOPQRSTUVWXYZ[\\\\]^_`abcdefghijklmnopqrstuvwxyz{|}~€\x81‚ƒ„…†‡ˆ‰\x8A‹Œ\x8D\x8E\x8F\x90‘’“”•–—˜™\x9A›œ\x9D == " !\\"#$%&'()*+,-./0123456789:;<=>?@ABCDEFGHIJKLMNOPQRSTUVWXYZ[\\\\]^_`abcdefghijklmnopqrstuvwxyz{|}~€\x81‚ƒ„…†‡ˆ‰\x8A‹Œ\x8D\x8E\x8F\x90‘’“”•–—˜™\x9A›œ\x9D
[task 2017-09-14T06:05:19.016303Z] 06:05:19     INFO -  (xpcshell/head.js) | test MAIN run_test finished (1)
[task 2017-09-14T06:05:19.016345Z] 06:05:19     INFO -  exiting test
[task 2017-09-14T06:05:19.016399Z] 06:05:19     INFO -  intl/uconv/tests/unit/test_decode_CP1258.js | Segmentation fault
[task 2017-09-14T06:05:19.016451Z] 06:05:19     INFO -  intl/uconv/tests/unit/test_decode_CP1258.js | 13
[task 2017-09-14T06:05:19.016490Z] 06:05:19     INFO -  <<<<<<<
[task 2017-09-14T06:05:19.455099Z] 06:05:19     INFO -  mozcrash Downloading symbols from: https://queue.taskcluster.net/v1/task/NFk6azFqTbqD7WqT4S_raw/artifacts/public/build/target.crashreporter-symbols.zip
[task 2017-09-14T06:05:23.959623Z] 06:05:23     INFO -  mozcrash Copy/paste: /builds/worker/workspace/build/linux64-minidump_stackwalk /tmp/tmpoJLthD/2d08a0a3-b488-1bfc-7e64-8207ded1353e.dmp /tmp/tmpfo4WNs
[task 2017-09-14T06:05:24.135132Z] 06:05:24     INFO -  mozcrash Saved minidump as /builds/worker/workspace/build/blobber_upload_dir/2d08a0a3-b488-1bfc-7e64-8207ded1353e.dmp
[task 2017-09-14T06:05:24.135837Z] 06:05:24     INFO -  mozcrash Saved app info as /builds/worker/workspace/build/blobber_upload_dir/2d08a0a3-b488-1bfc-7e64-8207ded1353e.extra
[task 2017-09-14T06:05:24.136512Z] 06:05:24  WARNING -  PROCESS-CRASH | intl/uconv/tests/unit/test_decode_CP1258.js | application crashed [@ libxul.so + 0x5f84ef]
[task 2017-09-14T06:05:24.137335Z] 06:05:24     INFO -  Crash dump filename: /tmp/tmpoJLthD/2d08a0a3-b488-1bfc-7e64-8207ded1353e.dmp
[task 2017-09-14T06:05:24.137837Z] 06:05:24     INFO -  Operating system: Android
[task 2017-09-14T06:05:24.138360Z] 06:05:24     INFO -                    0.0.0 Linux 2.6.29 #1 PREEMPT Thu Nov 7 22:27:50 UTC 2013 i686
[task 2017-09-14T06:05:24.139163Z] 06:05:24     INFO -  CPU: x86
[task 2017-09-14T06:05:24.139982Z] 06:05:24     INFO -       GenuineIntel family 6 model 3 stepping 3
[task 2017-09-14T06:05:24.140029Z] 06:05:24     INFO -       1 CPU
[task 2017-09-14T06:05:24.140447Z] 06:05:24     INFO -  GPU: UNKNOWN
[task 2017-09-14T06:05:24.141006Z] 06:05:24     INFO -  Crash reason:  SIGSEGV
[task 2017-09-14T06:05:24.141587Z] 06:05:24     INFO -  Crash address: 0x138
[task 2017-09-14T06:05:24.142071Z] 06:05:24     INFO -  Process uptime: not available
[task 2017-09-14T06:05:24.142525Z] 06:05:24     INFO -  Thread 2 (crashed)
[task 2017-09-14T06:05:24.142967Z] 06:05:24     INFO -   0  libxul.so + 0x5f84ef
[task 2017-09-14T06:05:24.143494Z] 06:05:24     INFO -      eip = 0xb39294ef   esp = 0xaf1ffe10   ebp = 0xaf1ffe48   ebx = 0xb7b10eec
[task 2017-09-14T06:05:24.144017Z] 06:05:24     INFO -      esi = 0xaf445e00   edi = 0xaf445e08   eax = 0x0f5cbacf   ecx = 0xaf445e14
[task 2017-09-14T06:05:24.144475Z] 06:05:24     INFO -      edx = 0x00055920   efl = 0x00000202
[task 2017-09-14T06:05:24.144949Z] 06:05:24     INFO -      Found by: given as instruction pointer in context
[task 2017-09-14T06:05:24.145387Z] 06:05:24     INFO -   1  libnss3.so + 0x8f9db
[task 2017-09-14T06:05:24.145927Z] 06:05:24     INFO -      eip = 0xb7de49db   esp = 0xaf1ffe50   ebp = 0xaf1ffe98
[task 2017-09-14T06:05:24.146412Z] 06:05:24     INFO -      Found by: previous frame's frame pointer
[task 2017-09-14T06:05:24.146849Z] 06:05:24     INFO -   2  libc.so + 0xf274
[task 2017-09-14T06:05:24.147318Z] 06:05:24     INFO -      eip = 0xb7bb8274   esp = 0xaf1ffea0   ebp = 0x00000000
[task 2017-09-14T06:05:24.147848Z] 06:05:24     INFO -      Found by: previous frame's frame pointer
[task 2017-09-14T06:05:24.148296Z] 06:05:24     INFO -   3  libnss3.so + 0x8f8bd
[task 2017-09-14T06:05:24.148754Z] 06:05:24     INFO -      eip = 0xb7de48bd   esp = 0xaf1ffec4   ebp = 0x00000000
[task 2017-09-14T06:05:24.149275Z] 06:05:24     INFO -      Found by: stack scanning
[task 2017-09-14T06:05:24.149730Z] 06:05:24     INFO -   4  libc.so + 0xf179
[task 2017-09-14T06:05:24.150189Z] 06:05:24     INFO -      eip = 0xb7bb8179   esp = 0xaf1ffedc   ebp = 0x00000000
[task 2017-09-14T06:05:24.150648Z] 06:05:24     INFO -      Found by: stack scanning
[task 2017-09-14T06:05:24.151071Z] 06:05:24     INFO -   5  libc.so + 0x26975
[task 2017-09-14T06:05:24.151725Z] 06:05:24     INFO -      eip = 0xb7bcf975   esp = 0xaf1ffef0   ebp = 0x00000000
[task 2017-09-14T06:05:24.152143Z] 06:05:24     INFO -      Found by: stack scanning
[task 2017-09-14T06:05:24.152651Z] 06:05:24     INFO -   6  libnss3.so + 0x8f8bd
[task 2017-09-14T06:05:24.153216Z] 06:05:24     INFO -      eip = 0xb7de48bd   esp = 0xaf1ffef4   ebp = 0x00000000
[task 2017-09-14T06:05:24.153781Z] 06:05:24     INFO -      Found by: stack scanning
Duplicate of this bug: 1406429
Duplicate of this bug: 1406580
Duplicate of this bug: 1402150
Duplicate of this bug: 1403309
Depends on: 1389805
Duplicate of this bug: 1415395
Alias: android-139
Duplicate of this bug: 1426976
Duplicate of this bug: 1426830
Duplicate of this bug: 1425951
Duplicate of this bug: 1428548
Duplicate of this bug: 1429397
See Also: → 1430176
Component: General → Testing
This failure indicates a crash in xpcshell during android xpcshell tests. Generally a crash dump is available and the crash is not "random", but the crash report is not helpful because of bug 1389805...so folks star or dup their failures here to say "hey, I can't make sense of this".

It's worth noting that some such crashes may be caused by assertions -- check the logcat artifact to see if there are any interesting failure messages prior to the crash.

Please do not report non-Android failures here.


To resolve this bug, we should resolve bug 1389805.
Priority: -- → P3
Duplicate of this bug: 1440078
Duplicate of this bug: 1445908
Duplicate of this bug: 1442223
With the recent resolution of bug 1389805, Android xpcshell crash reports have symbols now. As such, there should be no further need to dup bugs here -- new failure reports should be actionable and dealt with in their own bugs.
Assignee: nobody → gbrown
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1389805
Depends on: 1499915
No longer depends on: 1499915
You need to log in before you can comment on or make changes to this bug.