nsThreadManager uses XRE_IsContentProcess without including nsXULAppAPI.h

RESOLVED FIXED in Firefox 57

Status

()

Core
XPCOM
RESOLVED FIXED
a month ago
a month ago

People

(Reporter: philn, Assigned: philn)

Tracking

(Blocks: 1 bug)

Trunk
mozilla57
Points:
---

Firefox Tracking Flags

(firefox57 fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

a month ago
User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/60.0.3112.78 Safari/537.36

Steps to reproduce:

nsThreadManager.cpp is calling XRE_IsContentProcess() without including nsXULAppAPI.h, which results in a non-unified build failure.
(Assignee)

Updated

a month ago
Blocks: 1388605
(Assignee)

Comment 1

a month ago
Created attachment 8908074 [details] [diff] [review]
proposed.patch
Comment on attachment 8908074 [details] [diff] [review]
proposed.patch

I see no reason to ifdef this include; nothing in the file seems to be behind a windows check.
(Assignee)

Comment 3

a month ago
Created attachment 8908105 [details] [diff] [review]
proposed.patch
Attachment #8908074 - Attachment is obsolete: true
Attachment #8908105 - Flags: review?(erahm)
Comment on attachment 8908105 [details] [diff] [review]
proposed.patch

Review of attachment 8908105 [details] [diff] [review]:
-----------------------------------------------------------------

I claim my review powers cover this.
Attachment #8908105 - Flags: review+

Updated

a month ago
Assignee: nobody → philn
Keywords: checkin-needed

Comment 5

a month ago
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/38e7e0bba036
Include nsXULAppAPI.h in nsThreadManager.cpp. r=Ms2ger
Keywords: checkin-needed
Attachment #8908105 - Flags: review?(erahm)
https://hg.mozilla.org/mozilla-central/rev/38e7e0bba036
Status: UNCONFIRMED → RESOLVED
Last Resolved: a month ago
status-firefox57: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla57
You need to log in before you can comment on or make changes to this bug.