uBlock Origin stops pages from loading and hang up the process in charge of extension?

RESOLVED DUPLICATE of bug 1398099

Status

()

Firefox
Extension Compatibility
RESOLVED DUPLICATE of bug 1398099
7 months ago
5 months ago

People

(Reporter: Jack, Unassigned)

Tracking

({crash})

57 Branch
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 months ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20170913220121

Steps to reproduce:

Use ublock origin 1.14.8?  
It happens randomly so i dont't know.


Actual results:

A few weeks ago Nightly started to get stuck on loading websites, the gui works fine but when I enter a address it won't call it and it won't show anything loading in the status bar(lover left corner). Stuff like about:config will still load.  

When it gets stuck one content process will always stay at ~50% : https://i.imgur.com/ZTx12wu.png and some addons would not load(ublock, undo close tab button).
If i use task manager to kill the content process that stays at 50% everything will resume loading but ublock and other extensions would end up broken during that session, here is snoozetabs: https://i.imgur.com/QiJERGw.png, here is ublock: https://i.imgur.com/Y9itb2C.png and the ads would load.

Sometimes it will get unstuck if i disable ublock, sometimes if i disable another extension(I was disabling extensions one by one every 5 seconds and waiting to see if the websites starts loading, so the issue might still be ublock, it's just there is a delay until the loading resumes)

My extension: Firefox Notes v1.7.1, Kee v2.0.0.5, Mouse Gesture Events v1.5, snoozetabs v1.0.20, Test Pilot v2.0.2-dev-1c11ce2, uBlock Origin v1.14.8, Undo Close Tab Button v1.3, Testpilot containers v3.1.0.
Os: Windows 10 pro, insider build 16281, now on 16288..

I think the issue is ublock but I'm not quit sure since it happens randomly. I'm gonna disable ublock and see if i get this issue again.   

Here are some crashes, the only way to trigger a crash report when the browser is stuck and the content process is at 50% is by killing it or closing the browser:
https://crash-stats.mozilla.com/report/index/0d3dae15-deef-45d7-be82-954c30170914
https://crash-stats.mozilla.com/report/index/4cb32103-6f24-461d-a348-e90710170914
https://crash-stats.mozilla.com/report/index/a2122ab7-97e9-4459-8b47-a3c5d0170913
https://crash-stats.mozilla.com/report/index/410f8add-1185-45e4-b2eb-1d2170170911

Why this happens, I thought the switch to webextension would protect the browser from buggy extensions..
(Reporter)

Comment 1

7 months ago
Couldn't edit the report: 
This is what happens with the extensions when the content process is stuck at 50%, addons would not load..
https://i.imgur.com/y600z6d.png
(Reporter)

Comment 2

7 months ago
It's not ublock. Had the content process at 50% again and the pages would load. So when this happens it brakes ublock which results in sites not loading..
(Reporter)

Comment 3

7 months ago
After a few days of testing, the KeeFox 2.0.0.5 webextension seems to be the culprit.

Updated

7 months ago
Status: UNCONFIRMED → NEW
Component: Untriaged → Extension Compatibility
Ever confirmed: true
Keywords: crash

Comment 4

5 months ago
Based on comment 3.
Status: NEW → RESOLVED
Last Resolved: 5 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1398099
You need to log in before you can comment on or make changes to this bug.