Closed Bug 1399858 Opened 3 years ago Closed 3 years ago

NSS buildbot ABI check script fails if NSPR version on previous branch is unreleased

Categories

(NSS :: Build, enhancement)

3.32
enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: KaiE, Assigned: KaiE)

References

Details

Attachments

(1 file, 2 obsolete files)

When building NSS trunk, we look at the previous NSS version to obtain the NSPR version required by the previous NSS version, and then we try to pull that NSPR version. We do so by assuming that an NSPR branch for that previous NSPR version exists.

This fails shortly after branching a new NSS version, if that NSPR version hasn't been released yet, and we currently abort the test.

I suggest we fall back to pulling NSPR trunk.
Attached patch 1399858-v1.patch (obsolete) — Splinter Review
Attachment #8908108 - Flags: review?(franziskuskiefer)
Comment on attachment 8908108 [details] [diff] [review]
1399858-v1.patch

Doesn't work, because the output directory already exists
Attachment #8908108 - Attachment is obsolete: true
Attachment #8908108 - Flags: review?(franziskuskiefer)
Attached patch 1399858-v2.patchSplinter Review
Attachment #8908111 - Flags: review?(franziskuskiefer)
Attachment #8908111 - Flags: review?(franziskuskiefer) → review+
https://hg.mozilla.org/projects/nss/rev/88b6e9707b17
Target Milestone: --- → 3.34
can this be closed?
Flags: needinfo?(kaie)
Status: NEW → RESOLVED
Closed: 3 years ago
Flags: needinfo?(kaie)
Resolution: --- → FIXED
Attachment #8927553 - Attachment is obsolete: true
You need to log in before you can comment on or make changes to this bug.