Closed Bug 1399899 Opened 2 years ago Closed 2 years ago

Crash in mozilla::net::nsHttpChannel::TriggerNetwork

Categories

(Core :: Networking, defect, critical)

57 Branch
Unspecified
Windows 7
defect
Not set
critical

Tracking

()

RESOLVED FIXED
mozilla57
Tracking Status
firefox-esr52 --- unaffected
firefox55 --- unaffected
firefox56 --- unaffected
firefox57 --- fixed

People

(Reporter: calixte, Assigned: valentin)

References

(Blocks 1 open bug)

Details

(Keywords: crash, regression, Whiteboard: [clouseau])

Crash Data

This bug was filed from the Socorro interface and is 
report bp-8e5735b1-5dba-42f5-8daf-e0da70170914.
=============================================================

There are 56 crashes in nightly 57 with buildid 20170914100122. In analyzing the backtrace, the regression may have been introduced by patch [1] to fix bug 1399541.

[1] https://hg.mozilla.org/mozilla-central/rev?node=4198b9d273b9db50b5ffe4cdd078da073d8483db
Flags: needinfo?(valentin.gosu)
Crash Signature: [@ mozilla::net::nsHttpChannel::TriggerNetwork] → [@ mozilla::net::nsHttpChannel::TriggerNetwork] [@ mozilla::net::nsHttpChannel::TriggerNetwork [clone .cold.400]]
Duplicate of this bug: 1399884
Disabling nightly updates for now, Ryan will back this out of central.
"MOZ_RELEASE_ASSERT(sRCWNEnabled) (Racing should be enabled)" is in the crash reports.
Backed out from m-c. Today's second round of nightlies will have the fix.

https://hg.mozilla.org/mozilla-central/rev/943c2c2a1daf5cd0d3287c1974eb510615d5ed5b
Assignee: nobody → valentin.gosu
Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(valentin.gosu)
Resolution: --- → FIXED
Target Milestone: --- → mozilla57
You need to log in before you can comment on or make changes to this bug.