Searchfox not finding callers of WebRenderLayerManager::Initialize

RESOLVED DUPLICATE of bug 1397801

Status

Webtools
Searchfox
RESOLVED DUPLICATE of bug 1397801
3 months ago
a month ago

People

(Reporter: kats, Unassigned)

Tracking

Trunk

Firefox Tracking Flags

(Not tracked)

Details

http://searchfox.org/mozilla-central/search?q=symbol:_ZN7mozilla6layers21WebRenderLayerManager10InitializeEPNS0_22PCompositorBridgeChildENS_2wr10PipelineIdEPNS0_24TextureFactoryIdentifierE&redirect=false

doesn't show any uses of the function. However there are a few:

[1] http://searchfox.org/mozilla-central/rev/6326724982c66aaeaf70bb7c7ee170f7a38ca226/widget/nsBaseWidget.cpp#1293
[2] http://searchfox.org/mozilla-central/rev/6326724982c66aaeaf70bb7c7ee170f7a38ca226/dom/ipc/TabChild.cpp#2807
[3] http://searchfox.org/mozilla-central/rev/6326724982c66aaeaf70bb7c7ee170f7a38ca226/dom/ipc/TabChild.cpp#3139
This looks like a dupe of bug 1397801. I'll confirm that.
Status: NEW → RESOLVED
Last Resolved: a month ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1397801
I've confirmed that our patch for bug 1397801 matches the use to the definition for the places mentioned in comment 0 (aside from the one that no longer exists).
This affects a lot of places. 3600 different files see stuff added from this patch. There are no deletions. I spot checked a few symbols, and they were in fact missing the link.
You need to log in before you can comment on or make changes to this bug.