browser/base/content/test/performance/browser_startup_images.js fails in hdpi mode on Windows 10

RESOLVED FIXED in Firefox 57

Status

()

P3
normal
RESOLVED FIXED
a year ago
10 months ago

People

(Reporter: ahal, Assigned: johannh)

Tracking

unspecified
Firefox 58
x86_64
Windows 10
Points:
---

Firefox Tracking Flags

(firefox57 fixed, firefox58 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

a year ago
https://treeherder.mozilla.org/logviewer.html#?job_id=131089399&repo=try&lineNumber=4303

10:02:55     INFO -  101 INFO TEST-START | browser/base/content/test/performance/browser_startup_images.js
10:02:55     INFO -  TEST-INFO | started process screenshot
10:02:55     INFO -  TEST-INFO | screenshot: exit 0
10:02:55     INFO -  Buffered messages logged at 10:02:55
10:02:55     INFO -  102 INFO Entering test bound
10:02:55     INFO -  103 INFO TEST-FAIL | browser/base/content/test/performance/browser_startup_images.js | Whitelisted image chrome://global/skin/icons/resizer.png should not have been shown. -
10:02:55     INFO -  104 INFO TEST-PASS | browser/base/content/test/performance/browser_startup_images.js | Loaded image chrome://browser/skin/window-controls/minimize.svg should have been shown. -
10:02:55     INFO -  Buffered messages finished
10:02:55    ERROR -  105 INFO TEST-UNEXPECTED-FAIL | browser/base/content/test/performance/browser_startup_images.js | Loaded image chrome://browser/skin/window-controls/maximize.svg should have been shown. -

This was discovered while migrating tests from Windows 8 -> Windows 10 in bug 1397229. Since this was a newly added test and it also has some problems on Windows 7, it will be disabled on this platform (as part of bug 1397229). This bug will track fixing and re-enabling it.
(Reporter)

Updated

a year ago
OS: Unspecified → Windows 10
Hardware: Unspecified → x86_64
Priority: -- → P3
(Assignee)

Updated

a year ago
Duplicate of this bug: 1402089
(Assignee)

Updated

a year ago
Assignee: nobody → jhofmann
Status: NEW → ASSIGNED
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
(In reply to Johann Hofmann [:johannh] from comment #2)

> I also set the intermittentShown flag in case the Windows machines go back
> to non-maximized windows.

Should this be a comment in the test file?

Comment 7

a year ago
mozreview-review
Comment on attachment 8911092 [details]
Bug 1400357 - Whitelist maximize.svg in browser_startup_images.

https://reviewboard.mozilla.org/r/182588/#review187860

Thanks!
Attachment #8911092 - Flags: review?(florian) → review+
thanks for picking this up and getting a solution so quickly!
Comment hidden (mozreview-request)

Comment 10

a year ago
Pushed by jhofmann@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/43983cf4138e
Whitelist maximize.svg in browser_startup_images. r=florian

Comment 11

a year ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/43983cf4138e
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
status-firefox58: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 58
status-firefox57: --- → affected
Whiteboard: [checkin-needed-beta]

Comment 12

a year ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-beta/rev/00b34310a5c5
status-firefox57: affected → fixed
Whiteboard: [checkin-needed-beta]

Updated

10 months ago
Depends on: 1421460
You need to log in before you can comment on or make changes to this bug.