add flag to fetch_crashids.py for signature-contains

RESOLVED FIXED

Status

Socorro
General
RESOLVED FIXED
9 months ago
9 months ago

People

(Reporter: willkg, Assigned: willkg)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

One of the things I use the signature generation cli for is to check out signature generation changing pull requests to see if we end up with signatures that we like.

We have a fetch_crashids.py script which does a Super Search and returns crash ids that match the criteria.

It sure would be pretty awesome if fetch_crashids.py had a --signature-contains argument that I could pass a signature part to and have it return a bunch of crash ids for crashes with that signature part. Then I could pipe that to the signature generation cli and have a pretty solid tool for seeing how changes affect signature generation.

Something like this:

  $ scripts/fetch_crashids.py --num=10 "--signature-contains=std::_Hash<T>" | xargs python -m socorro.signature

This bug covers building that.
Assignee: nobody → willkg
Status: NEW → ASSIGNED
Created attachment 8908994 [details] [review]
pr 4000 - pull from stdin or command line args

Comment 2

9 months ago
Commit pushed to master at https://github.com/mozilla-services/socorro

https://github.com/mozilla-services/socorro/commit/cc9755a704a887aedc70318ad252c78d93cfb15f
fixes bug 1400402 - add --signature-contains to fetch_crashids script (#4000)

* fixes bug 1400402 - add --signature-contains to fetch_crashids script

This makes it muuuuch easier to test and regression test signature generation
changes.

* Adjust signature generator cli to take from stdin

Now the signature generator cli can take crash ids from the command line as well
as from stdin. This is nice because now we don't need the xargs.

Updated

9 months ago
Status: ASSIGNED → RESOLVED
Last Resolved: 9 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.