macOS: tab bar is obstructed by menus while using fullscreen mode

RESOLVED DUPLICATE of bug 738335

Status

()

Core
Widget: Cocoa
RESOLVED DUPLICATE of bug 738335
9 months ago
8 months ago

People

(Reporter: brandonshea@me.com, Unassigned)

Tracking

57 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

9 months ago
Created attachment 8908876 [details]
Screen Shot 2017-09-15 at 19.27.23.png

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20170915220136

Steps to reproduce:

- enter fullscreen mode
- move/throw mouse to the top of the screen to select tabs


Actual results:

- tab bar is obstructed by the menu bar, and you have to move the mouse away to see tabs again/select the one you want


Expected results:

- tab bar should slide down to accommodate the menus (same behavior as Chrome)

Updated

9 months ago
Component: Untriaged → Widget: Cocoa
Product: Firefox → Core
(Reporter)

Comment 1

9 months ago
This behavior is still present with 58.0a1 Nightly builds.

Comment 2

9 months ago
I noticed the same. I'll add a couple screenshots with references to how Safari behaves.

Comment 3

9 months ago
Created attachment 8914057 [details]
Safari Fullscreen

Comment 4

9 months ago
Created attachment 8914058 [details]
Safari Fullscreen with Menubar

Updated

8 months ago
Flags: needinfo?(spohl.mozilla.bugs)
Whiteboard: dupeme

Updated

8 months ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(spohl.mozilla.bugs)
Whiteboard: dupeme

Updated

8 months ago
Status: NEW → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 738335
You need to log in before you can comment on or make changes to this bug.