./mach try path/to/test does not work on Windows

RESOLVED DUPLICATE of bug 1413928

Status

RESOLVED DUPLICATE of bug 1413928
a year ago
8 months ago

People

(Reporter: emk, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
Probably because Python will convert slashes to native path separators (i.e. backslashes on Windows).

See this try run for example:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=827653c35153de71f21143cfd15b62b795de9b94

If I made a try-syntax changeset manually using slashes, it works:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=f4537f856c3f6c5560609111d615d510114a20a2

But ./mach try is going to be required for submitting to try (bug 1400330).

Please fix this before forcing us to use ./mach try.
Andrew, thoughts on how to approach this?
Flags: needinfo?(ahalberstadt)
The try syntax implementation of paths is pretty broken, there are at least 5-6 open bugs on it. Luckily, I have a patch series (which I hope to land sometime in January), which re-implements this functionality (bug 1413928). Until try syntax uses try_task_config.json, this will be fuzzy only. Though, as a follow-up to that work I plan to make sure just running |mach try <path>| will work.

I'm not going to have cycles to fix the existing implementation, and once the new |mach try <path>| implementation lands, I'd push to remove the old implementation entirely. So unless someone is willing to look into this in the interim, I think this bug will end up being WONTFIXed.
Flags: needinfo?(ahalberstadt)
See Also: → bug 1413928
I'll dup this forward, then.
Status: NEW → RESOLVED
Last Resolved: 10 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1413928

Updated

8 months ago
Product: TaskCluster → Firefox Build System
You need to log in before you can comment on or make changes to this bug.