Using Persona/Theme/Light Theme makes all buttons icons in Bars/Toolbars too dark after landing patch from bug #1384686

VERIFIED INVALID

Status

()

Firefox
Theme
VERIFIED INVALID
2 months ago
2 months ago

People

(Reporter: Virtual, Unassigned)

Tracking

({nightly-community})

57 Branch
x86_64
Windows 7
nightly-community
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(7 attachments)

STR:
1. Install Virtualfox Persona/Theme/Light Theme ( https://addons.mozilla.org/en-US/firefox/addon/virtualfox/ )
and see that all button icons color is changed to the black
while is should stay the same, like without any Theme

It's also inconsistent now with buttons icons color in Address Bar.

Regression caused by:
Bug #1384686

Regression pushlog:
https://hg.mozilla.org/mozilla-central/rev/7de50f562f6f542a1adbce4a39d533a898ea9afc
Created attachment 8908986 [details]
good build with Theme - proper icon color.png
Created attachment 8908987 [details]
good build with Theme - proper icon color (500%).png
Created attachment 8908988 [details]
bad build with Theme - wrong icon color.png
Created attachment 8908989 [details]
bad build with Theme - wrong icon color (500%).png
Created attachment 8908990 [details]
bad build without Theme - proper icon color.png
Created attachment 8908991 [details]
bad build without Theme - proper icon color (500%).png
According to
> (Tim Nguyen :ntim in bug #1384686 comment #3 wrote)
> > The spec says icons shouldn't be full black:
> > http://design.firefox.com/photon/visual/icons.html#color
I'm really in favor to standardizing all icons colors and make them all black (or white, depending on used theme), like it's in menus and submenus, as they're more visible per higher contrast to background.
Summary: Using Persona/Theme/Light Theme making all buttons icons in Bars/Toolbars too dark after landing patch from bug #1384686 → Using Persona/Theme/Light Theme makes all buttons icons in Bars/Toolbars too dark after landing patch from bug #1384686
Attachment #8908990 - Attachment description: bad build with Theme - proper icon color.png → bad build without Theme - proper icon color.png
Attachment #8908990 - Attachment filename: bad build with Theme - proper icon color.png → bad build without Theme - proper icon color.png
Attachment #8908991 - Attachment description: bad build with Theme - proper icon color (500%).png → bad build without Theme - proper icon color (500%).png
Attachment #8908991 - Attachment filename: bad build with Theme - proper icon color (500%).png → bad build without Theme - proper icon color (500%).png

Updated

2 months ago
Whiteboard: [photon-visual] [triage]

Comment 9

2 months ago
(In reply to Virtual_ManPL [:Virtual] - (please needinfo? me - so I will see your comment/reply/question/etc.) from comment #8)
> I'm really in favor to standardizing all icons colors and make them all
> black (or white, depending on used theme),

They're intentionally different with a lightweight theme applied, as lightweight themes have noisy backgrounds and need more contrast than the default theme.
Status: NEW → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → INVALID
Status: RESOLVED → VERIFIED
(In reply to Dão Gottwald [::dao] from comment #9)
> (In reply to Virtual_ManPL [:Virtual] - (please needinfo? me - so I will see
> your comment/reply/question/etc.) from comment #8)
> > I'm really in favor to standardizing all icons colors and make them all
> > black (or white, depending on used theme),
> 
> They're intentionally different with a lightweight theme applied, as
> lightweight themes have noisy backgrounds and need more contrast than the
> default theme.

So shouldn't also color of the buttons icons in the Address Bar be consistent too and be darker or brighter depending on used Theme?
Flags: needinfo?(dao+bmo)
The address bar is more opaque, so I don't think the same tradeoff with regards to contrast applies.
Flags: needinfo?(dao+bmo)
Created attachment 8909836 [details]
test-webext-theme.xpi

The icons are not only a bit darker, they use the text color as fill color.

Test with my test theme which makes the tab- and toolbar text red. And with this the icons are red too. Is this intended?
(In reply to Richard Marti (:Paenglab) from comment #12)
> Created attachment 8909836 [details]
> test-webext-theme.xpi
> 
> The icons are not only a bit darker, they use the text color as fill color.
> 
> Test with my test theme which makes the tab- and toolbar text red. And with
> this the icons are red too. Is this intended?

That's expected for now. I think there are plans to allow themes to customize the fill color separately from the text color.
No longer blocks: 1384686
status-firefox55: unaffected → ---
status-firefox56: unaffected → ---
status-firefox57: affected → ---
status-firefox-esr52: unaffected → ---
Keywords: regression, ux-consistency
You need to log in before you can comment on or make changes to this bug.