JavaScript strict warning: resource://gre/modules/TelemetryReportingPolicy.jsm, line 433: ReferenceError: reference to undefined property "FirsRunURL"

VERIFIED FIXED in Firefox 56

Status

()

defect
P1
normal
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: Tobbi, Assigned: Tobbi)

Tracking

({regression})

Trunk
mozilla57
Points:
---

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox55 unaffected, firefox56 verified, firefox57+ verified)

Details

Attachments

(1 attachment)

I am trying to write a Firefox extension and noticed the following in the console:
JavaScript strict warning: resource://gre/modules/TelemetryReportingPolicy.jsm, line 433: ReferenceError: reference to undefined property "FirsRunURL"

This seems to be a typo. I will fix it, as soon as I find out how this review process works.
Component: General → Telemetry
Product: Firefox → Toolkit
Comment on attachment 8909238 [details]
Bug 1400675 - Fix reference to undefined property FirsRunURL

https://reviewboard.mozilla.org/r/180836/#review186010

Thanks for the catch!
Attachment #8909238 - Flags: review?(gfritzsche) → review+
This was introduced in 56:
https://hg.mozilla.org/mozilla-central/rev/a86a44628486#l1.192

The affect will be:
- we can't use the background data policy tab (due to the typo)
- we fall back to the old data policy implementation
Dao, does that sound right to you?
Do you know from which release on we're using the background policy tab?
Flags: needinfo?(dao+bmo)
Severity: trivial → normal
Priority: -- → P1
[Tracking Requested - why for this release]:
This prevents us from using the new background privacy policy tab.
We have a fallback to the old policy bar, so it's not very critical.
(In reply to Georg Fritzsche [:gfritzsche] [away Sep 19 - Oct 3] from comment #4)
> Dao, does that sound right to you?

Yep.

> Do you know from which release on we're using the background policy tab?

Firefox 55 as far as I know (bug 1367076).
Flags: needinfo?(dao+bmo)
ni?pdol,canuckistani for a more product perspective of how bad it would be for us to, in 55, show the background tab and then, in 56, to go back to showing the infobar.

How hard do we want to push this for 56? Did this not get added to the 56 testplan?
Flags: needinfo?(pdolanjski)
Flags: needinfo?(jgriffiths)
Pushed by chutten@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/84bc19f5cbe5
Fix reference to undefined property FirsRunURL r=gfritzsche
https://hg.mozilla.org/mozilla-central/rev/84bc19f5cbe5
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla57
While I don't think this is dot-release-worthy, it's probably worth uplifting and riding along a potential 56 dot release. It seems low risk.
Flags: needinfo?(jgriffiths) → needinfo?(chutten)
Comment on attachment 8909238 [details]
Bug 1400675 - Fix reference to undefined property FirsRunURL

Approval Request Comment
[Feature/Bug causing the regression]: Telemetry First Run Data Collection Notice
[User impact if declined]: We show the data collection infobar instead of the background tab
[Is this code covered by automated tests?]: Nope
[Has the fix been verified in Nightly?]: Yes
[Needs manual test from QE? If yes, steps to reproduce]:  Please do. Start a fresh Beta profile and ensure that the Data Policy tab instead of the "Choose what I share" infobar
[List of other uplifts needed for the feature/fix]: None
[Is the change risky?]: Not really, no.
[Why is the change risky/not risky?]: It's a typo, and we already have a fallback for if it doesn't work.
[String changes made/needed]: None
Flags: needinfo?(chutten)
Attachment #8909238 - Flags: approval-mozilla-beta?
Comment on attachment 8909238 [details]
Bug 1400675 - Fix reference to undefined property FirsRunURL

56 is on release now.
Attachment #8909238 - Flags: approval-mozilla-beta? → approval-mozilla-release?
Comment on attachment 8909238 [details]
Bug 1400675 - Fix reference to undefined property FirsRunURL

Typo fix - this should be fine to uplift for 56 RC2.
Attachment #8909238 - Flags: approval-mozilla-release? → approval-mozilla-release+
Florin, do we have testing for first-run situations? bug 1367076 introduced a background tab opening with our privacy notice instead of the "Choose What I Share" infobar. We regressed the behaviour in 56, showing the infobar instead.
Flags: needinfo?(florin.mezei)
(In reply to Chris H-C :chutten from comment #15)
> Florin, do we have testing for first-run situations? bug 1367076 introduced
> a background tab opening with our privacy notice instead of the "Choose What
> I Share" infobar. We regressed the behaviour in 56, showing the infobar
> instead.

We don't have any dedicated test cases for first-run, mainly because it's constantly changing. However we can verify that this works correctly in 56 RC2 once it's available. Moving to Andrei for tracking.
Flags: qe-verify+
Flags: needinfo?(florin.mezei)
Flags: needinfo?(andrei.vaida)
Reproduced this issue using the STR from comment 11 on an affected Nightly build 57.0a1 (2017-09-17).

Verified fixed on 56.0 RC3 (2017092123461) and 57.0b2 (20170921191414) across platforms:
- Windows 10 x64
- Mac OS X 10.11.6
- Ubuntu 16.04 x64

The Data Policy page is properly loaded in the background tab - https://www.mozilla.org/en-US/privacy/firefox/ on a fresh profile, instead of the "Choose What I Share" infobar.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
Flags: needinfo?(andrei.vaida)
Flags: needinfo?(pdolanjski)
You need to log in before you can comment on or make changes to this bug.