Closed Bug 1400706 Opened 5 years ago Closed 5 years ago

Crash in mozilla::gfx::SourceSurfaceVolatileData::Map

Categories

(Core :: Graphics, defect)

Unspecified
Android
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 1400549

People

(Reporter: bkelly, Unassigned)

Details

(Keywords: crash)

Crash Data

This bug was filed from the Socorro interface and is 
report bp-0d49c26c-8d31-422e-9ae8-58a320170917.
=============================================================

Hit this three times today on fennec nightly 57.  Note, it's an asset:

MOZ_RELEASE_ASSERT(!mWasPurged)

Any ideas Milan?
Flags: needinfo?(milan)
This crash has occurred 2035 times on Mac in Nightly 20170916100147, which is an extraordinarily high number. But I don't see it at all in the two Nightly builds prior and the two Nightly builds afterwards, which is weird.

It is only happening on Mac and Fennec, which is also interesting.

aosmond, it looks like you touched this code most recently. Any ideas?
Flags: needinfo?(aosmond)
I backed it out as soon as I realized the crash rate was what it was, hence why it spiked and went away. We were trying to collect some data, thinking the repro rate of something was much lower than it actually was.
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: needinfo?(aosmond)
Resolution: --- → DUPLICATE
Duplicate of bug: 1400549
Flags: needinfo?(milan)
You need to log in before you can comment on or make changes to this bug.