Closed Bug 1400751 Opened 2 years ago Closed 2 years ago

Bookmark star and Pocket animations are misaligned in touch mode

Categories

(Firefox :: Toolbars and Customization, defect)

57 Branch
x86
Windows 10
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 57
Tracking Status
firefox57 --- fixed

People

(Reporter: jkt, Assigned: adw)

References

Details

Attachments

(2 files)

Attached image bookmark-icon.PNG
Bookmarking a page aligns the item wrong in the lastest nightly.
See attached.
Is this with compact density, or normal or touch, and always or for some pages or when the window is small, or only mid-animation, or only with the light/dark theme or something? Does it also happen when the page isn't bookmarked?

(I can't reproduce after trying several configurations)
Flags: needinfo?(jkt)
Summary: Bookmarking an icon looks misaligned → Bookmark star icon looks misaligned in bookmarked state
Also, what dpi setting are you using in Windows? And is this a regression, and if so, any chance you can find a regression window?
Also, does it happen without the container label in the urlbar?
Touch density in Windows. Containers doesn't make a difference. This happens through the whole animation and finishes like that.
Soon as I click the icon it moves, the default position is correct.

I'm using 150% scaling within windows itself on a 42" inch 4k monitor on 3840x2160 res.

I haven't modified the default dpi in about:config.
Flags: needinfo?(jkt)
It also replicates on my 4k screen for the laptop too, the scaling appears to be set to the same though which perhaps might be the issue?
At 100% scaling the issue seems to be the same too.
Depends on: 1400812
Looks like this regressed around the time of bug 1397583. I can only reproduce in touch mode. Jonathan, does that match what you're seeing?
Blocks: 1397583
Flags: needinfo?(jkt)
Summary: Bookmark star icon looks misaligned in bookmarked state → Bookmark star animation is misaligned in touch mode
No longer depends on: 1400812
Confirm, it looks like a regression and I can only reproduce with touch mode.
Flags: needinfo?(jkt)
I see it too.  I must have screwed up the touch part of bug 1397583.
Assignee: nobody → adw
Status: NEW → ASSIGNED
Yikes, I copy-pasted a selector from the star button CSS into Pocket's CSS but didn't actually update it after that.  Which means that not only is the animated star button wrong in touch mode, the animated Pocket button is, too.
Summary: Bookmark star animation is misaligned in touch mode → Bookmark star and Pocket animations are misaligned in touch mode
OK, I tested this with both the star and Pocket buttons on all three densities on Windows, and on both densities on macOS.
Comment on attachment 8909435 [details]
Bug 1400751 - Bookmark star and Pocket animations are misaligned in touch mode.

https://reviewboard.mozilla.org/r/180942/#review186132
Attachment #8909435 - Flags: review?(gijskruitbosch+bugs) → review+
https://hg.mozilla.org/mozilla-central/rev/ff7917ed161f
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 57
You need to log in before you can comment on or make changes to this bug.