Site navigation bar does not update after change in DOM

RESOLVED DUPLICATE of bug 109307

Status

RESOLVED DUPLICATE of bug 109307
17 years ago
13 years ago

People

(Reporter: pstark, Assigned: samir_bugzilla)

Tracking

({helpwanted})

Trunk
Future
helpwanted

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0rc1)
Gecko/20020417
BuildID:    2002041711

Links in the Site Navigation Bars are not updated after a change in the DOM on
the LINK elements. 

I want to be able to dynamically change the Site Navigation Bars by using
JavaScript/DOM. 

Reproducible: Always
Steps to Reproduce:
1. Create a link in the Site Navigation Bar by using the LINK element
2. Update the value of the "href" attribute on the LINK element using
Javascript/DOM in the Web page
3. Click on the link in Site Navigation Bar that corresponds to the updated link. 


Actual Results:  The link has not changed.

Expected Results:  The link would change to the new values set by the
JavaScript/DOM call in the Web page.
Not tabbed browser....  Stuart?  drbrain?  can one of you take this?  (you'd
have to trap modification events and act on them, but that'll be a perf hit,
unfortunately....)
Assignee: jaggernaut → sgehani
Status: UNCONFIRMED → NEW
Component: Tabbed Browser → XP Apps
Ever confirmed: true
Keywords: helpwanted
OS: Windows 2000 → All
QA Contact: sairuh → paw
Hardware: PC → All
(Assignee)

Updated

17 years ago
Target Milestone: --- → Future

Comment 2

17 years ago
I could have *sworn* there was already a bug on this, but I might be wrong.
Somebody with more time than me might want to trawl bug 103053's deps and see if
they can find it...

It is in fact already (hopefully - I've never tested it, but the code is there)
possible to add *new* links to the document through the DOM and have them work.
Unfortunately, the code doesn't keep a bidirectional mapping between the <link>
object and the toolbar item (at least as far as I've found so far) which makes
it hard to catch dynamic updates. To some extent, the code is actually
gratuitously bad at this: the LinkElementDecorator pattern used actually copies
the href rather than using it. But the general case of the problem requires more
work.

One prerequisite is another DOM event like DOMLinkChanged that would get fired
when at least the "rel" or "rev" attributes of a link element get changed, and
perhaps "title" too. We should be at least able to handle href without that,
though.
Blocks: 103053

*** This bug has been marked as a duplicate of 109307 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.