Closed Bug 140084 Opened 19 years ago Closed 19 years ago

BACKGROUND property for COL elements not being applied in Mozilla 1.0 rc1

Categories

(Core :: CSS Parsing and Computation, defect)

x86
Windows 98
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 4510

People

(Reporter: val, Assigned: dbaron)

Details

Attachments

(1 file)

User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.0rc1) Gecko/20020417
BuildID:    2002041711

(Note: this is a regression bug - I don't know when it appeared, but the
BACKGROUND property on COL elements appears to work fine in Mozilla 0.9.6)

The TABLE in the attached testcase has a COL structure of:

<col><col><col class="marked">

with the following styles:

col {
 width:100px;
 border:2px solid red;
 background:#ffcccc;
}

.marked {
 width:200px;
 border:2px solid blue;
 background:#aaccee;
}

The WIDTH and BORDER properties are being applied, but not the BACKGROUND property.
Duplicate of "table element backgrounds not working correctly"

*** This bug has been marked as a duplicate of 4510 ***
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.