Website sorely needs redesign

RESOLVED DUPLICATE of bug 114175

Status

www.mozilla.org
General
RESOLVED DUPLICATE of bug 114175
16 years ago
5 years ago

People

(Reporter: Ian Clarke, Assigned: Dawn Endico)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
www.mozilla.org, while fine for a geeky open source project, really needs a
total redesign for 1.0 if it is to be a destination for what will hopefully be
hoardes of newbies, sick of I.E, who want an alternative.  The current website
is too "busy", not very asthetically pleasing when compared to other websites
that target the common-man, and makes it way to difficult for people to find the
"Download" link for the latest version of the software.

Comment 1

16 years ago
This is a dupe of bug 114175.

*** This bug has been marked as a duplicate of 114175 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Product: mozilla.org → Websites
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.