scrolling out in json viewer

RESOLVED FIXED in Firefox 58

Status

defect
P3
normal
RESOLVED FIXED
2 years ago
Last year

People

(Reporter: yuraantonov11, Assigned: Oriol)

Tracking

(Blocks 1 bug)

57 Branch
Firefox 58
Dependency tree / graph

Firefox Tracking Flags

(firefox57 wontfix, firefox58 fixed)

Details

Attachments

(2 attachments)

Posted image Screenshot_1.jpg
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20170918100059

Steps to reproduce:

I open developer tools with ajax request witch returns json.


Actual results:

when i select some row in response and move down with arrows on keyboard, selected row in json goes beyond


Expected results:

when i select some row in response and move down with arrows on keyboard, selected row in json should not go beyond, and json should scroll down
Component: Untriaged → Developer Tools
Component: Developer Tools → Developer Tools: Netmonitor
Status: UNCONFIRMED → NEW
Has STR: --- → yes
Component: Developer Tools: Netmonitor → Developer Tools: JSON Viewer
Ever confirmed: true
Also occurs when open an json (json viewer) and scrolling.
Summary: scrolling in dev tools → scrolling out in json viewer
Blocks: 1376748
Assignee: nobody → oriol-bugzilla
Status: NEW → ASSIGNED
`document` is not available in the DOM panel, which uses TreeView too. So I switched to `ReactDOM.findDOMNode`.
Comment on attachment 8924147 [details]
Bug 1400963 - Scroll selected row into view in JSON Viewer.

https://reviewboard.mozilla.org/r/195408/#review200988

Thanks for the patch!

R+ assuming try is green

Honza

::: devtools/client/jsonview/test/browser_jsonview_row_selection.js:12
(Diff revision 2)
> +
> +add_task(function* () {
> +  info("Test JSON row selection started");
> +
> +  // Create a tall JSON so that there is a scrollbar.
> +  let numRows = 1e3;

heh, creative way to say `1000` ;-)
Attachment #8924147 - Flags: review?(odvarko) → review+
There was a conflict in browser.ini when I applied the patch.
You might want to check it out before landing.

Honza
(In reply to Jan Honza Odvarko [:Honza] from comment #6)
> There was a conflict in browser.ini when I applied the patch.

Thanks, rebased the patch.

(In reply to Jan Honza Odvarko [:Honza] from comment #5)
> heh, creative way to say `1000` ;-)

I tend to use exponential notation for big numbers; not much useful for 1000, though.
Keywords: checkin-needed
hg error in cmd: hg rebase -s bd3edec1b462 -d 1c1e25c461a0: abort: can't rebase public changeset bd3edec1b462
(see 'hg help phases' for details)
I don't understand, what am I supposed to do to?
Flags: needinfo?(ryanvm)
Redirecting to someone who knows MozReview :)
Flags: needinfo?(ryanvm) → needinfo?(mcote)
Fixed a typo in the test. I still don't know what's with this phases problem.
glob, you know what's happening here?
Flags: needinfo?(mcote) → needinfo?(glob)
db7d4a3601e5's phase is public; it should be draft:
> $ hg log -T '{node} {phase}\n' -r db7d4a3601e5
> db7d4a3601e51281e1c8057acdfcb500c415b65d public

the revision from comment 12 looks correct:
> $ hg log -T '{node} {phase}\n' -r a5606bc28432
> a5606bc28432368fe5d4e7f9285d61cf04997cef draft

i can't tell how db7d4a3601e5 was changed to public – it's likely this was an accidental action by oriol.

setting checkin-needed as it looks like a5606bc28432 should be ok.
Flags: needinfo?(glob)
Keywords: checkin-needed
We're sorry, Autoland could not rebase your commits for you automatically. Please manually rebase your commits and try again.

hg error in cmd: hg rebase -s 03d59dbc349a -d e412b3da631e: rebasing 432460:03d59dbc349a "Bug 1400963 - Scroll selected row into view in JSON Viewer. r=Honza" (tip)
merging devtools/client/shared/components/tree/TreeView.js
warning: conflicts while merging devtools/client/shared/components/tree/TreeView.js! (edit, then use 'hg resolve --mark')
unresolved conflicts (see hg resolve, then hg rebase --continue)
Rebased the patch
Keywords: checkin-needed
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/ba9156f71b76
Scroll selected row into view in JSON Viewer. r=Honza
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/ba9156f71b76
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 58
Depends on: 1415919
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.