Does not handle preformatted text tag properly

VERIFIED WORKSFORME

Status

--
trivial
VERIFIED WORKSFORME
17 years ago
13 years ago

People

(Reporter: srtedg, Assigned: bugs)

Tracking

({fonts})

Trunk
x86
Linux
fonts

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0rc1) Gecko/20020417
BuildID:    2002041711

The pre tag isn't handled properly, (checked with netscape, lynx and IE, html is
alright)..

Reproducible: Always
Steps to Reproduce:
1.Just have to go to website where pre tag is used
2.
3.
renders fine as far as I can tell (Linux trunk build 2002-04-24-07).  What
exactly do you see wrong with the rendering?

Over to layout, since <pre> is not a form control.
Assignee: rods → attinasi
Component: HTML Form Controls → Layout
QA Contact: tpreston → petersen

Comment 2

17 years ago
Dup of bug 139978
David, did you comment on the wrong bug or put down the wrong bug number?

Comment 5

17 years ago
Boris: commented in w0rng bug, sorry :-) I meant to post this to bug 140102.
Time to go to bed and stop bug-hunting ...
I'm getting a normal proportional font in a Linux CVS trunk build.
Keywords: fonts

Comment 7

17 years ago
worksforme with Linux trunk build 20020424 and 1.0rc1
Mail from Matt:

Sorry for the delay, had to wait till I got back into work.

Fonts for: Western
Proportoinal: Serif size 16
Serif: adobe-times-iso8859-1
Sans-Serif: adobe-helvetica-iso8859-1
Cursive: abisource-arial-iso8859-1
Fantasy: abisource-arial-iso8859-1
Monospace: adobe-helvetica-iso8859-15    size 16

Minimum font size: None

Checked: Allow documents to use other fonts

Display resolution: 96dpi

I don't recall changing any of these, so I'm pretty sure they are the
defaults
> Monospace: adobe-helvetica-iso8859-15

This is the problem.  adobe-helvetica is not a monospace font.  You set it as
your monospace font, so we use it for <pre> elements...

I just tried taking a current build and creating a brand new profile.  The
default monospace font (and for that matter cursive/fantasy) came up as
adobe-courier (which _is_ monospace).

This sounds like a "self-changing" preference problem if anything, not layout.

Choess, are your font settings screwed up too?
Assignee: attinasi → ben
Component: Layout → Preferences
QA Contact: petersen → sairuh
Huh?  I guess I wasn't clear with my last comment, I have adobe courier for
monospace, WFM.
no answer
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
mass-verifying WorksForMe bugs.

reopen only if this bug is still a problem with a *recent trunk build*.

mail search string for bugspam: AchilleaMillefolium
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.