Closed Bug 1401018 Opened 4 years ago Closed 4 years ago

about:addons search steals focus from add-on preferences textbox

Categories

(Toolkit :: Add-ons Manager, defect, P1)

56 Branch
defect

Tracking

()

VERIFIED FIXED
mozilla57
Tracking Status
firefox-esr52 --- unaffected
firefox55 --- unaffected
firefox56 --- wontfix
firefox57 --- verified

People

(Reporter: aswan, Assigned: aswan)

References

Details

(Keywords: regression)

Attachments

(1 file)

+++ This bug was initially created as a clone of Bug #1381032 +++

The fix in bug 1381032 handled this problem when OOP webextensions are enabled, but not if they are disabled.  Cloning to handle the latter case separately.

STR:
1) Install Gecko Profiler from https://perf-html.io
2) Navigate to about:addons -> Extensions -> Gecko Profiler [Options]
3) Type a URL (containing forward slash) into |Profile viewer URL| box

Expected:
Can enter a URL including forward slashes

Actual:
A forward slash in URL appears in textbox, then focus switches to settings searchbar and rest of URL appears there.
Attachment #8909508 - Flags: review?(kmaglione+bmo)
Comment on attachment 8909508 [details]
Bug 1401018 Don't let about:addons steal keypresses from options pages

https://reviewboard.mozilla.org/r/180984/#review186302
Attachment #8909508 - Flags: review?(kmaglione+bmo) → review+
Pushed by aswan@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/de928fb12391
Don't let about:addons steal keypresses from options pages r=kmag
Krupa, can we get a little extra QA attention on this?  I'm pretty confident that we're addressing the original symptom properly but want to make sure we're not inadvertently stealing keypresses for other things (i.e., browser level keyboard shortcuts, etc)
Flags: needinfo?(krupa.mozbugs)
https://hg.mozilla.org/mozilla-central/rev/de928fb12391
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla57
Based on the testing I did for the bug 1381032, the result of which you can find accessing this link https://bugzilla.mozilla.org/show_bug.cgi?id=1381032#c13, I think this bug can be closed.
Status: RESOLVED → VERIFIED
Flags: needinfo?(krupa.mozbugs)
This bug is verified on Firefox 57.0b9 (20171016185129) and Firefox 58.0a1 (20171016100113) under Windows 10 64bit/Mac OS X 10.13.
Duplicate of this bug: 784335
You need to log in before you can comment on or make changes to this bug.