yale.edu - RC1 seems to have problems that 0.9.9 didn't have

RESOLVED FIXED

Status

RESOLVED FIXED
17 years ago
4 years ago

People

(Reporter: mattiasottervik, Unassigned)

Tracking

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.0rc1)
Gecko/20020417
BuildID:    20020417

After logging in to classes.yale.edu (need a valid Yale student ID number) the
top frame displays an error message. This page has worked in all previous
Mozilla builds.






Reproducible: Always
Steps to Reproduce:
1. Log in with valid Yale NetID (have provided Javascript source in description)
2.
3.

Actual Results:  Got an error message:
---------------------------------------------
JRun Servlet Error
---------------------------------------------


StNav:

java.lang.NumberFormatException: 1.0rc1


---------------------------------------------

Expected Results:  To display it as it does in IE and Moz builds prior to RC 1.

The Javascript looks like this:
<HTML><HEAD>
<SCRIPT LANGUAGE='Javascript'>
<!--
var relpg = 'JAPN 119-2b';
function loadgen(go)
{
garr = go.split('|');
eval("parent.gen.location.replace('https://classes.yale.edu/servlet/" + garr[0]
+ "')");
document.indbox.src ='https://classes.yale.edu/jsp/' + garr[1];
}
function loadmat(go)
{
garr = go.split('|');
parent.gen.location.replace('https://classes.yale.edu/servlet/StSort?dir=materials&sort=alpha');
document.indbox.src ='https://classes.yale.edu/jsp/' + garr[1];
}
function loadupl(go)
{
garr = go.split('|');
eval("parent.gen.location.replace('https://classes.yale.edu/servlet/StUploadPage')");
document.indbox.src ='https://classes.yale.edu/jsp/' + garr[1];
}
function gotop()
{
top.gotop(document.forms[0].chopage.options[document.forms[0].chopage.selectedIndex].value)
}
function smallframe()
{
var nextyear = new Date(2002, 9, 1);
document.cookie = "framesize=small; expires=" + nextyear.toGMTString();
top.gotop(relpg + '&Sect=true');
}
function bigframe()
{
var nextyear = new Date(2002, 9, 1);
document.cookie = "framesize=big; expires=" + nextyear.toGMTString();
top.gotop(relpg + '&Sect=true');
}
//-->
</SCRIPT>
<STYLE type='text/css'>
<!--
.boldFont {
font-family: verdana, arial, helvetica, sans-serif;
font-weight: bold;
font-size: small;
}
//-->
</STYLE>
<LINK REL='StyleSheet' HREF='https://classes.yale.edu/jsp/instruct.css'
TYPE='text/css'>
<META HTTP-EQUIV='Pragma' CONTENT='no-cache'>
<META HTTP-EQUIV='Expires' CONTENT='0'>
</HEAD>
<BODY bgcolor='#FFFFFF' marginwidth='0' marginheight='0'>
<font face='verdana, arial, helvetica, sans-serif' size=-1>
<TABLE border=0 cellpadding=0 cellspacing=0>
<tr>
<TD bgcolor='#000000' width=1 rowspan=3><img
src='https://classes.yale.edu/jsp/blackspace.gif' suppress='true' width='1'></td>
<TD bgcolor='#000000'><img src='https://classes.yale.edu/jsp/blackspace.gif'
suppress='true' height='1'></TD>
<TD bgcolor='#000000' width=1 rowspan=3><img
src='https://classes.yale.edu/jsp/blackspace.gif' suppress='true' width='1'></td>
<TD bgcolor='#000000'><img src='https://classes.yale.edu/jsp/blackspace.gif'
suppress='true' height='1'></TD>
<TD bgcolor='#000000' width=1 rowspan=3><img
src='https://classes.yale.edu/jsp/blackspace.gif' suppress='true' width='1'></td>
<TD bgcolor='#000000'><img src='https://classes.yale.edu/jsp/blackspace.gif'
suppress='true' height='1'></TD>
<TD bgcolor='#000000' width=1 rowspan=3><img
src='https://classes.yale.edu/jsp/blackspace.gif' suppress='true' width='1'></td>
<TD bgcolor='#000000'><img src='https://classes.yale.edu/jsp/blackspace.gif'
suppress='true' height='1'></TD>
<TD bgcolor='#000000' width=1 rowspan=3><img
src='https://classes.yale.edu/jsp/blackspace.gif' suppress='true' width='1'></td>
<TD bgcolor='#000000'><img src='https://classes.yale.edu/jsp/blackspace.gif'
suppress='true' height='1'></TD>
<TD bgcolor='#000000' width=1 rowspan=3><img
src='https://classes.yale.edu/jsp/blackspace.gif' suppress='true' width='1'></td>
<TD bgcolor='#000000'><img src='https://classes.yale.edu/jsp/blackspace.gif'
suppress='true' height='1'></TD>
<TD bgcolor='#000000' width=1 rowspan=3><img
src='https://classes.yale.edu/jsp/blackspace.gif' suppress='true' width='1'></td>
<TD rowspan='3' valign='bottom'><a href='javascript:smallframe() //'
onMouseOver="status='Reduce size of top frame'; return true;"
onMouseOut="status='';"><img src='https://classes.yale.edu/jsp/shrinkbox.gif'
height='10' width='14' border='0' alt='Shrink the top frame'></A></TD>
</tr><tr>
<TD bgcolor='#11A41F' height='50' width='92' align=center><font face='verdana,
arial, helvetica, sans-serif' size=-1><font size='-1'>&nbsp;<b><a
href="javascript:loadgen('StViewHomePage?japn119-2b|stgreen.gif')"
onMouseOver="status='Class web pages - last updated Jan 9, 2002 6:20 PM'; return
true;" onMouseOut="status='';"><font color='#FFFFFF'>Web
Page</font></B></a>&nbsp;</font></td>
<TD bgcolor='#EE2C2C' height='50' width='92' align=center><font face='verdana,
arial, helvetica, sans-serif' size=-1><font size='-1'>&nbsp;<b><a
href="javascript:loadgen('StViewSyllabus?japn119-2b|stred.gif')"
onMouseOver="status='No syllabus on classes.yale.edu for this course'; return
true;" onMouseOut="status='';"><font
color='#FFFFFF'>Syllabus</font></B></a>&nbsp;</TD>
<TD bgcolor='#EE9A00' height='50' width='92' align=center><font face='verdana,
arial, helvetica, sans-serif' size=-1><font size='-1'>&nbsp;<b><a
href="javascript:loadmat('StSort|storange.gif')" onMouseOver="status='Class
Materials - last updated Jan 9, 2002 6:20 PM'; return true;"
onMouseOut="status='';"><font color='#FFFFFF'>Materials</font></B></a>&nbsp;</TD>
<TD bgcolor='#1042D6' height='50' width='92' align=center><font face='verdana,
arial, helvetica, sans-serif' size=-1><font size='-1'>&nbsp;<b><a
href="javascript:loadupl('StUploadPage|stblue.gif')" onMouseOver="status='Upload
a file'; return true;" onMouseOut="status='';"><font
color='#FFFFFF'>Upload</font></B></a>&nbsp;</TD>
<TD bgcolor='#006400' height='50' width='92' align=center><font face='verdana,
arial, helvetica, sans-serif' size=-1><font size='-1'>&nbsp;<b><a
href="javascript:loadgen('StChat?japn119-2b|stdgreen.gif')"
onMouseOver="status='Online chat - last posting Sep 23, 1999 5:09 AM'; return
true;" onMouseOut="status='';"><font color='#FFFFFF'>Chat</font></B></a>&nbsp;</TD>
<TD bgcolor='#000080' height='50' width='92' align=center><font face='verdana,
arial, helvetica, sans-serif' size=-1><font size='-1'>&nbsp;<b><a
href="javascript:loadgen('StNewsG?japn119-2b|stnavy.gif')"
onMouseOver="status='Discussion group - no postings on classes.yale.edu for this
course'; return true;" onMouseOut="status='';"><font
color='#FFFFFF'>Newsgroup</font></B></a>&nbsp;</TD>
</tr><tr>
<TD bgcolor='#000000'><img src='https://classes.yale.edu/jsp/blackspace.gif'
height='1'></TD>
<TD bgcolor='#000000'><img src='https://classes.yale.edu/jsp/blackspace.gif'
height='1'></TD>
<TD bgcolor='#000000'><img src='https://classes.yale.edu/jsp/blackspace.gif'
height='1'></TD>
<TD bgcolor='#000000'><img src='https://classes.yale.edu/jsp/blackspace.gif'
height='1'></TD>
<TD bgcolor='#000000'><img src='https://classes.yale.edu/jsp/blackspace.gif'
height='1'></TD>
<TD bgcolor='#000000'><img src='https://classes.yale.edu/jsp/blackspace.gif'
height='1'></TD>
</tr><tr>
<td colspan=13 bgcolor='#EEE9E9' align=center>
<table border=0 cellspacing=0 cellpadding=0><tr>
<td valign=top><img src='https://classes.yale.edu/jsp/stgreen.gif' height=6
width=6 vspace=10 hspace=5 border=0 name=indbox></td>
<td valign=top><form class='boldFont'><SELECT name='chopage' onChange='gotop()'>
<OPTION VALUE='JAPN 119-2b' SELECTED>Japanese 119-2b
<OPTION VALUE='ECON 150b'>Economics 150b
<OPTION VALUE='ECON 161b'>Economics 161b
<OPTION VALUE='MCDB 110b'>Molecular Cellular & Dev Biol 110b
</SELECT></form></td>
<td valign=top><font face='verdana, arial, helvetica' size='-1'>
<img src='https://classes.yale.edu/jsp/transpace.gif' height='3' width='100'
vspace='1' border='0' suppress='true'><br>
&nbsp;&nbsp;<b>Elementary  Japanese III</b></td>
</tr></table>
</td></tr></table><br></BODY></HTML>

Comment 1

17 years ago
From 

http://java.sun.com/products/jdk/1.1/docs/api/java.lang.NumberFormatException.ht
ml


public class NumberFormatException 
extends IllegalArgumentException 

Thrown to indicate that the application has attempted to convert a string to one 
of the numeric types, but that the string does not have the appropriate format. 

See Also: toString 

Comment 2

17 years ago
Created attachment 81046 [details]
HTML from reporter

Comment 3

17 years ago
Note: I only modified this part of the given HTML:

I've replaced      |parent.gen.location.replace|
         with      |location.replace|


However, when we click on the colored tabs, we get redirected to

        https://classes.yale.edu/student/sessionexpire.html,

which says that a Yale login is required -

Comment 4

17 years ago
OK, it looks like this is what's happening:

Compare the reporter's userAgent string for RC1 to 
the one for the 0.9.9 release:

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.0rc1)
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:0.9.9+)


Now look at the Java servlet error reported above:

---------------------------------------------
JRun Servlet Error
---------------------------------------------
StNav:
java.lang.NumberFormatException: 1.0rc1


Apparently the Yale server-side code is doing browser-sniffing
and attempting to derive the version number from the userAgent string.
For the 0.9.9 release, it had no trouble doing this.


But for the RC1 release, it finds the string "rv:1.0rc1" above.
Because of the "rc" in this string, the server-side Java code
is unable to convert this into a number, hence the error:

             java.lang.NumberFormatException


Since this is a server-side coding error, reassigning to 
Tech Evangelism to get this corrected at Yale.
Assignee: rogerl → doron
Status: UNCONFIRMED → NEW
Component: JavaScript Engine → US Edu
Ever confirmed: true
Product: Browser → Tech Evangelism
QA Contact: pschwartau → caillon
Summary: RC 1 seems to have problems with Javascript that 0.9.9 didn't have → RC1 seems to have problems that 0.9.9 didn't have
Version: other → unspecified

Updated

16 years ago
Summary: RC1 seems to have problems that 0.9.9 didn't have → yale.edu - RC1 seems to have problems that 0.9.9 didn't have

Comment 5

16 years ago
tech evang june 2003 reorg
Assignee: doron → english-us
Component: US Edu → English US
QA Contact: z-caillon-obsolete2 → english-us
I assume it's fixed, you get a 403 from outside
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.