Closed Bug 1401158 Opened 2 years ago Closed 2 years ago

about:home is broken and doesn't work/load as redirects to about:newtab after landing patch from bug #1396274

Categories

(Firefox :: New Tab Page, defect, critical)

57 Branch
x86_64
Windows 7
defect
Not set
critical

Tracking

()

VERIFIED INVALID

People

(Reporter: Virtual, Unassigned)

Details

(Keywords: nightly-community)

Attachments

(2 files)

[Tracking Requested - why for this release]: Regression

STR:
1. Set your homepage as "about:home"
2. Open homepage
and see that about:home is broken and doesn't work/load as redirects to about:newtab
BTW. I liked old behavior where I could nearly completely blank New Tab (about:newtab) and still have proper Firefox homepage (about:home) as independent one.
Blocks: 1396274
Has Regression Range: --- → yes
Summary: about:home is broken and doesn't work/load as redirects to about:newtab → about:home is broken and doesn't work/load as redirects to about:newtab after landing patch from bug #1396274
Workaround:
Set "chrome://browser/content/abouthome/aboutHome.xhtml" as homepage to get back proper Firefox homepage
If you turn off stuff from about:newtab, it won't show stuff on the about:home version.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
You can also turn off browser.newtabpage.activity-stream.aboutHome.enabled
(In reply to Ed Lee :Mardak from comment #5)
> If you turn off stuff from about:newtab, it won't show stuff on the
> about:home version.

Yes, that's the point of this bug, which is that now about:home and about:newtab share settings.
I don't want to merge settings of about:home and about:newtab,
as they have other goals for me, because I want to have:
- about:home - old good and fast features buttons (Downloads/Bookmarks/History/Add-ons/Snyc/Options/Restore Previous Session)
- about:newtab - simply blank without any useless bloat slowing down opening new tabs.

Also about:home has "New Tab" as title, which is clearly wrong for Firefox internal Start Page.
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
It's by design that activity stream is on about:home. If you don't want it that way, you can at least set the preference from comment 6.
Status: REOPENED → RESOLVED
Closed: 2 years ago2 years ago
Resolution: --- → WONTFIX
(In reply to Ed Lee :Mardak from comment #8)
> It's by design that activity stream is on about:home.
So maybe change this design?
As it's kinda illogical.

(In reply to Ed Lee :Mardak from comment #8)
> If you don't want it that way, you can at least set the preference from comment 6.
Thanks for this but hiding settings from users and making them use about:config is simply bad UX design.

Please reconsider this.
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
As requested, this is WONTFIX. about:home is not "broken" as you have turned off settings.
Status: REOPENED → RESOLVED
Closed: 2 years ago2 years ago
Resolution: --- → WONTFIX
(In reply to Ed Lee :Mardak from comment #10)
> As requested, this is WONTFIX. about:home is not "broken" as you have turned
> off settings.

But before, I had normal Firefox internal Start Page, which was about:home,
not some odd redirection to New Tab (about:newtab),
now I need to set "chrome://browser/content/abouthome/aboutHome.xhtml" as homepage
or change "browser.newtabpage.activity-stream.aboutHome.enabled" to "false" as you wrote.

In future probably, when users will want to have other settings for homepage and other for new tab like me, there will be problem. Fortunately this could be changed by extension.
about:home is still loading Firefox's internal Start Page. It's still about:home.
(In reply to Ed Lee :Mardak from comment #12)
> about:home is still loading Firefox's internal Start Page. It's still
> about:home.

Not in Nightly,
as about:home loads/redirects to about:newtab, see attached screenshots.
Only when "browser.newtabpage.activity-stream.aboutHome.enabled" is set to "false", as you wrote, user get proper Firefox internal Start Page, not New Tab.
Activity Stream is on both about:home and about:newtab. about:home is not redirecting to about:newtab.
(In reply to Ed Lee :Mardak from comment #14)
> Activity Stream is on both about:home and about:newtab. about:home is not
> redirecting to about:newtab.

Not it Nightly,
please see attached screenshots,
as it's clearly shown there that "about:home" tab name is "New Tab".
It is by design that the name of about:home shows "New Tab"
Oh... so let it be, if it really by some kinda of designed design.
Status: RESOLVED → VERIFIED
Component: Activity Streams: Newtab → New Tab Page
You need to log in before you can comment on or make changes to this bug.