Closed Bug 1401195 Opened 2 years ago Closed 2 years ago

The below part of the Tab Bar doesn't react on double-clicks when Dark theme is enabled

Categories

(Core :: Widget: Cocoa, defect, P3)

57 Branch
All
macOS
defect

Tracking

()

VERIFIED FIXED
mozilla60
Tracking Status
firefox55 --- wontfix
firefox56 --- wontfix
firefox57 --- wontfix
firefox60 --- verified
firefox72 --- verified
firefox73 --- verified
firefox74 --- verified

People

(Reporter: Ovidiu, Assigned: mstange)

References

Details

Attachments

(1 file)

[Affected versions]:

FF release 55, FF beta 56, FF Nightly 57.0a1(2017-09-18)

[Affected platforms]:

Mac OS 

[Steps to reproduce]:

1. Go to Customize and enabled "Dark" or "Light" theme
2. Double-click on the Tab Bar (in the area from the middle to the bottom)

[Expected result]:

The window should expand/shrink 

[Actual result]:

Nothing happens.


[Additional notes]:

This issue is a follow-up from https://bugzilla.mozilla.org/show_bug.cgi?id=1399930#c20
Flags: qe-verify+
Whiteboard: [photon-visual][triage]
No longer blocks: 1349552
Flags: qe-verify+
Whiteboard: [photon-visual][triage]
Did this regress at some point before 55 or has this just always been broken?
Flags: needinfo?(ovidiu.boca)
I tried with FF 50 release and I can still reproduce this.
Flags: needinfo?(ovidiu.boca)
Duplicate of this bug: 1423351
It seems, that in FF59, the Light Theme is fixed. But the Dark Theme is still broken.


FF57
====
  Light: broken
   Dark: broken



FF58
====
  Light: broken
   Dark: broken



FF59
====
  Light: works
   Dark: broken
(In reply to Mehmet from comment #4)
> It seems, that in FF59, the Light Theme is fixed. But the Dark Theme is
> still broken.

Would be interesting to know when exactly it got fixed so we can apply the same fix to the Dark theme.
(In reply to Dão Gottwald [::dao] from comment #5)
> (In reply to Mehmet from comment #4)
> > It seems, that in FF59, the Light Theme is fixed. But the Dark Theme is
> > still broken.
> 
> Would be interesting to know when exactly it got fixed so we can apply the
> same fix to the Dark theme.

Presumably in bug 1417709 which introduced -moz-mac-vibrant-titlebar-light/dark to avoid the -moz-window-titlebar hack (which is described in that bug) we've been using on OSX, but that didn't fix for dark theme of course.
(In reply to Johann Hofmann [:johannh] from comment #6)
> (In reply to Dão Gottwald [::dao] from comment #5)
> > (In reply to Mehmet from comment #4)
> > > It seems, that in FF59, the Light Theme is fixed. But the Dark Theme is
> > > still broken.
> > 
> > Would be interesting to know when exactly it got fixed so we can apply the
> > same fix to the Dark theme.
> 
> Presumably in bug 1417709 which introduced
> -moz-mac-vibrant-titlebar-light/dark to avoid the -moz-window-titlebar hack
> (which is described in that bug) we've been using on OSX, but that didn't
> fix for dark theme of course.

So enabling vibrancy in the Dark theme would fix this. We didn't do that for aesthetic reasons (bug 1386721 comment 10).

Short of enabling vibrancy, we need to fix dragging by other means. This rule is generally supposed to take care of this:

https://searchfox.org/mozilla-central/rev/588d8120aa11738657da93e09a03378bcd1ba8ec/browser/base/content/browser.css#285-287

Is this ineffective on Mac? Is window dragging also broken with third-party lightweight themes?
Summary: The below part of the Tab Bar doesn't react on double-clicks when Dark or Light theme is enabled → The below part of the Tab Bar doesn't react on double-clicks when Dark theme is enabled
> Short of enabling vibrancy, we need to fix dragging by other means.

Dragging works fine, it's just double-clicking to minimize which doesn't work.

To fix this, #TabsToolbar needs -moz-appearance: -moz-window-titlebar, or -moz-mac-vibrant-titlebar-light/dark, but either of those will change the appearance.

It would be better if the titlebar double-clicking behavior were associated with -moz-window-dragging: drag; rather than a -moz-appearance value.

Markus, what do you think >
Flags: needinfo?(mstange)
To be clear, atm, #TabsToolbar uses -moz-appearance: none; on the dark theme, -moz-appearance: -moz-mac-vibrant-titlebar-light; on the light theme, and -moz-mac-vibrant-titlebar-dark on the default theme.
(In reply to Tim Nguyen :ntim from comment #8)
> It would be better if the titlebar double-clicking behavior were associated
> with -moz-window-dragging: drag; rather than a -moz-appearance value.

I think the reason that this wasn't done initially was that we had some windows with draggable bottom bars, for example the pre-arrowpanel Downloads window, and double-clicking on those wasn't supposed to do anything special. I was also under the assumption that for example the Favorites bar in Safari doesn't react to double clicks, but it appears I was wrong about that.

So it looks like there's no compelling reason for treating double click behavior separately from dragging behavior any more.
Assignee: nobody → mstange
Status: NEW → ASSIGNED
Flags: needinfo?(mstange)
Comment on attachment 8957649 [details]
Bug 1401195 - Make double-clicking draggable parts of the window always do the titlebar-double-click action, regardless of whether the click targeted the titlebar or some other draggable element.

https://reviewboard.mozilla.org/r/226556/#review232446
Attachment #8957649 - Flags: review?(spohl.mozilla.bugs) → review+
Pushed by mstange@themasta.com:
https://hg.mozilla.org/integration/autoland/rev/5e9db9c66ccd
Make double-clicking draggable parts of the window always do the titlebar-double-click action, regardless of whether the click targeted the titlebar or some other draggable element. r=spohl
Thanks for looking at this so quickly!

Does this mean that the code associating different -moz-appearance values to the double click behaviour can be cleaned up ?
Component: Theme → Widget: Cocoa
Product: Firefox → Core
If you think it's valuable, sure. Changing the list of recognized -moz-appearance values is always a bit of a hassle because you need to coordinate checkins to stylo and autoland, though...
https://hg.mozilla.org/mozilla-central/rev/5e9db9c66ccd
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla60
Great, thank you very much! Works fine in latest Nightly 60.0a1 (2018-03-10) (64-Bit).

This issue is verified as fixed since Firefox version 60, flags will be updated.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.