Closed Bug 1401217 Opened 2 years ago Closed 2 years ago

containers testpilot icon disappears from nav bar after update restart

Categories

(Firefox :: Toolbars and Customization, defect, P1)

57 Branch
defect

Tracking

()

RESOLVED FIXED
Iteration:
57.3 - Sep 19
Tracking Status
firefox57 --- affected

People

(Reporter: aki, Unassigned)

References

Details

(Whiteboard: [reserve-photon-structure])

STR:

- install Fx nightly (OSX for me)
- install containers testpilot addon https://testpilot.firefox.com/experiments/containers
- add containers icon (4 squares in a square, except the top right square is a `+`) to nav bar
- restart Fx nightly for an update

Expected result:
- containers icon is in nav bar

Actual result:
- containers icon is missing. Upon a quit and reopen, the containers icon reappears.

Per https://bugzilla.mozilla.org/show_bug.cgi?id=1385630#c66 , the output of 

    CustomizableUI.getWidgetIdsInArea("nav-bar");

is:

    Array [ "customizableui-special-spring144", "back-button", "forward-button", "stop-reload-button", "urlbar-container", "downloads-button", "new-tab-button", "_testpilot-containers-browser-action", "pocket-button", "jid1-mnnxcxisbpnsxq_jetpack-browser…", 7 more… ]

7 more includes "action-button--testpilot-addon-main" "_cd7e22de-2e34-40f0-aeff-cec824cbccac_-browser-action" "snoozetabs_mozilla_com-browser-action" "_forest-firefox-addon-browser-action" "screenshots_mozilla_org-browser-action" "library-button" "geckoprofiler_mozilla_com-browser-action"
Thanks so much for the prompt response and bug filing.

Good news: I'm 99% sure this will be fixed by bug 1399517. I think it's because of the old "pocket-button" placement that's still in your navbar. TBH, I'm a bit surprised *only* the containers item would disappear and not the other items that occur after the containers item... but anyway. Let's wait until 1399517 lands. I'll track this so I remember to doublecheck with you that the issue is fixed after that lands.
Blocks: 1399517
Flags: qe-verify-
Priority: -- → P4
Whiteboard: [reserve-photon-structure]
Hey Aki, this should be fixed on yesterday's "late" nightly (buildid 20170919220202), or today's nightly if that's simpler. Can you confirm that it's fixed for you, too?
Flags: needinfo?(aki)
Yes! I have the containers icon on update-restart. Thank you!
Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(aki)
Resolution: --- → FIXED
Iteration: --- → 57.3 - Sep 19
Priority: P4 → P1
Thanks Gijs, I think there was a another filed on behalf of Aki for this exact bug. I will chase it down.

Thanks both.
You need to log in before you can comment on or make changes to this bug.