If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Printing tables - lines missing

RESOLVED FIXED in Future

Status

()

Core
Printing: Output
P3
normal
RESOLVED FIXED
16 years ago
4 years ago

People

(Reporter: Brian Foddy, Assigned: rods (gone))

Tracking

Trunk
Future
Sun
Solaris
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux ppc; en-US; rv:0.9.8) Gecko/20020310
BuildID:    2002041818

When the referenced page is printed to a HP 2100 postscript
printer, several of the table cells seperator lines are missing.

Incorrect results sometimes present in print preview also,
but many times are different.

Reproducible: Always
Steps to Reproduce:
1.Load the page
2.Print to printer
3.

Actual Results:  Later records in printout are missing seperators, especially
on page 2.

Expected Results:  Every record (as defined by the Flight Number column) should
be seperated by a line and the table formatted consistently.

The problem seems to happen only with longer tables, one and
two records don't have the problem.  Problem is more
prevalent on the second page, but not limited to.

I had to blank out the text on this page for confidential 
reasons.
Whiteboard: DUPEME

Comment 1

16 years ago
Created attachment 86384 [details]
HTML file containing large tables formatted with CSS

I'm using Mozilla 1.0 RC3 on a PIII 500Mhz PC running Windows 2000 SP2.

Large tables (bigger than one page) are printed/print previewed incorrectly.

Small tables are OK. As soon as tables get longer than one page
printing/previewing is not done correctly. The lines on the second, third ...
pages are shown without lines.

There are three tables in the attached HTML file. The first one is small enough
to fit on one page and therefore printed/previewed correctly. The second and
third tables are printed/previewed correctly on their according start page. The
following pages are printed/previewed without lines.

Comment 2

16 years ago
Comment on attachment 86384 [details]
HTML file containing large tables formatted with CSS

When printing CSS formatted tables bigger than one page the table lines
(graphics) are missing starting at page 2. The attached HTML-File shows 3
tables of different sizes. The first one fits on one page and is printed
correctly. The other ones need several pages and are printed correctly only on
the respectiv first page.
This  can be seen in print preview too.
doe sthis still exist in 1.1beta?
(Reporter)

Comment 4

15 years ago
I tried testing it with 1.1b that I personally compiled on
Solaris 2.8 (no precompiled version available on the web/ftp sites).

Unfortunately, the browser frequently crashes while trying to print
examples that are contained in this bug.

Please see bug #161967 for details of that new bug I opened.
(Reporter)

Comment 5

15 years ago
I just re-ran the my tests with the patch for #159358 included
(to fix the crash).  I only get table boundaries on the first
page of the tables.  The second pages have no table cell lines.
So I would have to say the problem is still there in 1.1beta.

Comment 6

15 years ago
Created attachment 107811 [details]
Blowup of testcase, page 3

Using nightly 2002112908. I loaded the testcase, printed it to a file, and
looked at it with ghostview. All of the vertical lines seem to be fine, but
several of the horizontal lines are unusually thin. In some cases the line is
virtually invisible when viewing the printout at normal scale, but by zooming
in the line can be seen. The attached image shows one of these zoomed to 800%.

Brian, is this the problem you're seeing?
(Reporter)

Comment 7

15 years ago
I think you are on to something.  I just looked at an internal example
(sorry, I can't post it without a lot of content removal), printed it
and there are VERY faint lines when printed on a high resolution
PS printer.  So faint, they almost look like they are see through from 
the back side but they aren't.  I don't have GV handy, only
GS and I don't see a zoom option on it (if there is, I have a
.ps file I can also view).

Comment 8

15 years ago
Okay, I think that's good enough to confirm this. I also suspect this has to do
with pixel rounding, so I'm going to add this to bug 134942, the pixel roundoff
tracking bug.
Blocks: 134942
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

15 years ago
Priority: -- → P3
Target Milestone: --- → Future

Comment 9

14 years ago
I tested this with a CVS build from 20031106 and I can't reproduce the effect
any more. This was probably fixed by the patch for bug 80190.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED

Updated

4 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.