Closed Bug 1401244 Opened 2 years ago Closed 2 years ago

Update webrender to 2a005f156b9f25862a2dc8443b57be37168233f2

Categories

(Core :: Graphics: WebRender, enhancement, P1)

58 Branch
enhancement

Tracking

()

RESOLVED FIXED
mozilla58
Tracking Status
firefox58 --- fixed

People

(Reporter: kats, Assigned: kats)

References

(Blocks 2 open bugs)

Details

(Whiteboard: [wr-mvp] [gfx-noted])

Attachments

(3 files, 1 obsolete file)

+++ This bug was initially created as a clone of Bug #1400216 +++

I'm filing this as a placeholder bug for the next webrender update. I may be running a cron script [1] that does try pushes with webrender update attempts, so that we can track build/test breakages introduced by webrender on a rolling basis. This bug will hold the try push links as well as dependencies filed for those breakages, so that we have a better idea going into the update of what needs fixing. I might abort the cron job because once things get too far out of sync it's hard to fully automate fixing all the breakages.

When we are ready to actually land the update, we can rename this bug and use it for the update, and then file a new bug for the next "future update".

[1] https://github.com/staktrace/moz-scripts/blob/master/try-latest-webrender.sh
WR @ 595ef5f759cf126c19c195cf57569d6f14fef8ad

https://treeherder.mozilla.org/#/jobs?repo=try&revision=809142a5df0c3b1599cca4e84d038698de4b3f0b

Busted

Regression range:
*   595ef5f7 Auto merge of #1734 - glennw:bump-mac-deps, r=mrobinson
|\
| * 40e7bb2f Update mac library dependencies.
*   1d5acc27 Auto merge of #1726 - glennw:frame-tidy, r=mrobinson
|\
| * 195946fc Move ImageBorderSegment to border.rs
| * 49475f58 Remove unused struct
| * 8ff2c289 Remove a HashMap in the Scene structure.
| * 4ee4b44b Move try_to_add_rectangle_splitting_on_clip to be a free function
| * 55e447e6 Move StackingContextHelpers from Frame -> Scene
| * 2f9ca3e2 Move FilterOpHelpers from Frame -> Scene.
* 7328cb4f Auto merge of #1721 - glennw:synthetic, r=nical
* 4dbc5d8e Implement synthetic italics on Linux.

Bustage appears to be from 4dbc5d8e
This should fix the bustage by doing more or less the same thing we have done with other exposed types that upset cbindgen (like ImageDescriptor).
This seems to work, although I had to s/FontInstanceOptions/WrFontInstanceOptions/ in a couple of places in gfx/2d/2D.h. Thanks!
WR @ 6e8bda75ef2eb7dc7fd3f7431d8c2ce7526dfc1d

https://treeherder.mozilla.org/#/jobs?repo=try&revision=10233a155f3f28b9d9d834dcd58dda4fa88b8a48
https://treeherder.mozilla.org/#/jobs?repo=try&revision=a44252a99bebe2395b6837f3eefa8a2dd771ab49

OS X build bustage is my fault, I didn't catch all the mac-specific fixes needed. Decision task failure on the windows push is bug 1402233.

WR @ 7a5f60aff33010a44d6acbdc67f27f1f63678b5d

https://treeherder.mozilla.org/#/jobs?repo=try&revision=6e474083dde57747c0b4673746001e0a58801ce9
https://treeherder.mozilla.org/#/jobs?repo=try&revision=4a878c00a315d85d24b4d4ad13e8d0b815691a1a

Other way around here. decision task failure is on the more useful push so that's a bummer.
A bit of a tricky update, this one. Because the update needs to land interleaved with the patches from bug 1397458, and those patches are not in MozReview, I can't autoland them. So all of this needs to land on inbound if it wants to stay together. Unfortunately this patchset also includes a bunch of lockfile updates so if servo changes on autoland cause merge conflicts we'll just get backed out and I don't want to take that risk.

Even if we move Lee's patches on bug 1397458 into MozReview so I can autoland them, those patches are interleaved into the patches from this bug. So I would need to split this update into two parts; the first update up to 2a005f156b9f25862a2dc8443b57be37168233f2 with Lee's patches. The second update would be to WR tip and include nical's patch.

Sigh.
This bug is going to be for the first update, to 2a005f156b9f25862a2dc8443b57be37168233f2.
Alias: wr-future-update
Assignee: nobody → bugmail
Summary: Future webrender update bug → Update webrender to 2a005f156b9f25862a2dc8443b57be37168233f2
Version: unspecified → 58 Branch
Comment on attachment 8911139 [details]
Bug 1401244 - Update webrender to commit 2a005f156b9f25862a2dc8443b57be37168233f2.

https://reviewboard.mozilla.org/r/182640/#review187918
Attachment #8911139 - Flags: review?(jmuizelaar) → review+
Comment on attachment 8911140 [details]
Bug 1401244 - Update Cargo lockfiles.

https://reviewboard.mozilla.org/r/182642/#review187920
Attachment #8911140 - Flags: review?(jmuizelaar) → review+
Comment on attachment 8911141 [details]
Bug 1401244 - Update call to set_window_parameters for API change in WR cset f88825b.

https://reviewboard.mozilla.org/r/182644/#review187922
Attachment #8911141 - Flags: review?(jmuizelaar) → review+
Pushed by kgupta@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a76983d302de
Update webrender to commit 2a005f156b9f25862a2dc8443b57be37168233f2. r=jrmuizel
https://hg.mozilla.org/integration/autoland/rev/d209ec686f4f
Update Cargo lockfiles. r=jrmuizel
https://hg.mozilla.org/integration/autoland/rev/bdfb0bd22f08
Update call to set_window_parameters for API change in WR cset f88825b. r=jrmuizel
Comment on attachment 8910821 [details] [diff] [review]
Add WrFontInstanceOptions (FontInstanceOptions without Option)

This patch is going to go in bug 1402304, in the next update (aka the second part of this two-part update).
Attachment #8910821 - Attachment is obsolete: true
Priority: P3 → P1
Whiteboard: [gfx-noted] → [wr-mvp] [gfx-noted]
This may have broken text some of the time on Linux. See bug 1402585
You need to log in before you can comment on or make changes to this bug.