White line in Modern's progress meter area.

VERIFIED FIXED

Status

VERIFIED FIXED
17 years ago
11 years ago

People

(Reporter: stephend, Assigned: stephend)

Tracking

({polish})

Trunk
polish

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

Build ID: 2002-04-25-06, Windows 2000+Modern only (doesn't happen on Linux/Mac).

Summary: White line in Modern's progress meter area.

Steps to Reproduce:

1.  When the progress meter is at rest, look at the bottom of that section.

Expected Results:

Same color throughout.

Actual Results:

There exists a small white line (horizontal) at the bottom of the progress meter
area.  Screenshot forthcoming.
Actually, I do see it on linux. Build 2002042507.
*** Bug 140854 has been marked as a duplicate of this bug. ***

Comment 4

17 years ago
My comments from bug 140854:

This was caused by Hyatt's changes to themes/modern/global/progressmeter.css 
for bug 115748:

 .progressmeter-statusbar {
   margin: 0;
-  border-bottom: none;
+  border-bottom: 2px solid transparent;
   -moz-border-top-colors: #E0ECF6 #C7D0D9;

If I change back to the original version, the progress meter looks better.  Why 
was the modern theme changed for that bug?  That bug was for OS theme support, 
and we only support themes in classic.

Comment 5

17 years ago
Created attachment 81617 [details] [diff] [review]
patch

This reverts to what it was before Hyatt's checkin.
Keywords: patch, review
OS: Windows 2000 → All
Hardware: PC → All

Comment 6

17 years ago
Any chance of some r=/sr= lovin' on this one line cosmetic fix-up?

Comment 7

17 years ago
Comment on attachment 81617 [details] [diff] [review]
patch

Actually, I think a better fix would to change that line to:

-moz-border-bottom-colors: transparent transparent;
Attachment #81617 - Flags: needs-work+

Comment 8

17 years ago
Perhaps.  I was just trying to revert what was changed to the previous version.
Hewitt's suggestion is great.  Re-assigning, attaching patch in a moment.
Assignee: shliang → stephend

Comment 12

17 years ago
Comment on attachment 85946 [details] [diff] [review]
Fix (hewitt's suggestion)

Fantastic work Stephen, you've outdone yourself once again!
Attachment #85946 - Flags: superreview+ → review+
Fix on trunk.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Keywords: patch, review → adt1.0.1
Resolution: --- → FIXED

Comment 14

17 years ago
Looks much better using 2002060308.  Verified Fixed.
Status: RESOLVED → VERIFIED
Nominating for nsbeta1, so that Nav triage can evaluate this one.

IMHO - I think its a good candidate for buffy.
Keywords: nsbeta1, polish
adt1.0.1- (on behalf of the ADT) as there is very little, real user benefit
here. let's get it into to buffy.
Keywords: adt1.0.1, nsbeta1 → adt1.0.1-, nsbeta1-

Comment 17

17 years ago
It's a very safe cosmetic fix, though.  Why not clean up the UI?

Comment 18

17 years ago
Why not fix the bugs we *need* for MachV first?  How can Netscape engineers
justify spending time on bugs like this when we have such a large list of
nsbeta1+ bugs?  

Comment 19

17 years ago
I didn't realize it took a lot of time to check in a patch that already exists.
It takes a lot of aggregated time to eat, sleep, and defecate too, and those
don't all come before MachV in a strict priority order -- a truly Stakhanovite
Netscape engineer would fix all approved bugs first, then eat, sleep, defecate,
or keel over (the good of the release having been served).  :-/

Mozilla's trunk needs module owner, reviewer, and super-reviewer cycles, we've
fought and won this point repeatedly (I recall fighting with jar during 6.0 over
it).  Let's not go there again.  Netscape has generally been committed to
supporting Mozilla's posterity, not to blindly micro-managing minute-long tasks
that fall under the duties of owners and reviewers.  I'm confident that will
continue in general to be true.

But it surely is demotivating and demoralizing to be micro-managed, and to spend
more minutes defending what's right and proper.  Bleah.

/be

Comment 21

17 years ago
*** Bug 125745 has been marked as a duplicate of this bug. ***
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.