when loading a temporary add-on the last folder should be remembered

RESOLVED FIXED in Firefox 68

Status

defect
P1
normal
RESOLVED FIXED
2 years ago
2 months ago

People

(Reporter: kernp25, Assigned: jdescottes)

Tracking

(Blocks 1 bug)

unspecified
Firefox 68
Dependency tree / graph

Firefox Tracking Flags

(firefox57 wontfix, firefox68 fixed)

Details

(Whiteboard: [remote-debugging-reserve])

Attachments

(2 attachments)

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20170919100405

Steps to reproduce:

1. Go to about:debugging
2. Click the "Load Temporary Add-on" button and select a WebExtension
3. Restart the browser


Actual results:

I have to navigate everytime to the folder to load the add-on. (default is downloads folder)


Expected results:

It should remember the last folder where the add-on was loaded.
I generally find web-ext more convenient for this.
Priority: -- → P5
Component: Add-ons Manager → Developer Tools: about:debugging
Product: Toolkit → Firefox
Product: Firefox → DevTools

This is really annoying bug to me. It does not make sense to share the default folder of file picker with last download folder...

Why don't you put the last folder into new pref here:
https://searchfox.org/mozilla-central/source/devtools/client/aboutdebugging-new/src/modules/extensions-helper.js#102-138
and set fp.displayDirectory to the nsIFile instance created with the pref value?

Status: UNCONFIRMED → NEW
Ever confirmed: true
See Also: → 1514564
Priority: P5 → P3
Duplicate of this bug: 1471394
Assignee: nobody → jdescottes
Status: NEW → ASSIGNED
Priority: P3 → P1
Whiteboard: [remote-debugging-reserve]
Pushed by jdescottes@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ecc1127396f9
Remember last folder used to load a temporary extension r=daisuke
https://hg.mozilla.org/integration/autoland/rev/1f27cacfb9cf
Add mochitest for remembering temporary addon folder; r=daisuke
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 68
Regressions: 1549684
You need to log in before you can comment on or make changes to this bug.