Closed Bug 1401412 Opened 3 years ago Closed 3 years ago

Objects destroyed too late in shutdown

Categories

(Core :: XPCOM, enhancement)

enhancement
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla57
Tracking Status
firefox57 --- fixed

People

(Reporter: mrbkap, Assigned: mrbkap)

References

Details

Attachments

(1 file)

When my content processes shutdown, I get:

  [Child 3738, Main Thread] WARNING: XPCOM objects created/destroyed from static ctor/dtor: file /home/mrbkap/work/main/mozilla/xpcom/base/nsTraceRefcnt.cpp, line 171

using a debugger, this turns out to be the InputEventStatistics object [1]. It uses a static singleton which is only torn down after everything else is torn down. We should avoid doing that.
Assignee: nobody → mrbkap
Comment on attachment 8910056 [details]
Bug 1401412 - Destroy this singleton during XPCOM shutdown.

https://reviewboard.mozilla.org/r/181530/#review187026
Attachment #8910056 - Flags: review?(bugs) → review+
Pushed by mrbkap@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/5a44548cb570
Destroy this singleton during XPCOM shutdown. r=smaug
https://hg.mozilla.org/mozilla-central/rev/5a44548cb570
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla57
Duplicate of this bug: 1401763
You need to log in before you can comment on or make changes to this bug.