Closed Bug 1401442 Opened 3 years ago Closed 2 years ago

Firefox developer help link overlaps content pane of preferences

Categories

(Firefox :: Preferences, defect, P4)

57 Branch
defect

Tracking

()

RESOLVED FIXED
Firefox 58
Tracking Status
firefox-esr52 --- unaffected
firefox55 --- unaffected
firefox56 --- unaffected
firefox57 --- wontfix
firefox58 --- fixed

People

(Reporter: mark.bokil, Assigned: evanxd)

Details

Attachments

(5 files, 1 obsolete file)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20170917031738

Steps to reproduce:

Open Preferences from menu


Actual results:

Firefox developer help link overlaps content pane of preferences


Expected results:

Firefox developer help link should sit pretty in the corner and not overlap
Status: UNCONFIRMED → NEW
Component: Untriaged → Preferences
Ever confirmed: true
Whiteboard: [photon-preferences]
Summary: preferences → Firefox developer help link overlaps content pane of preferences
Hey Evan, we should wrap this text because I'm sure some locales will display long strings here for Release versions of Firefox. Can you take this?
Flags: needinfo?(evan)
Priority: -- → P4
Sure, I could help this.
Assignee: nobody → evan
Status: NEW → ASSIGNED
Flags: needinfo?(evan)
Whiteboard: [photon-preferences] → [photon-preference][triage]
Attached image current-nightly.png
Attached image patched-nightly.png (obsolete) —
Attachment #8925822 - Attachment is obsolete: true
Attached image patched-nightly.png
Hi Jared,

This issues had been fixed by Bug 1400203, check attachment 8925829 [details] to see the screenshot of Preferences in current Firefox Developer Edition.

But we still have an align issue in current Nightly (attachment 892582), the patch[1] is for fixing it. And the result looks like this attachment 8925830 [details].

Could you help review the patch[1]?
Thank you very much.

[1]: https://reviewboard.mozilla.org/r/197004/diff/2#index_header
Attachment #8925818 - Flags: review?(jaws)
(In reply to Evan Tseng [:evanxd] from comment #9)
> But we still have an align issue in current Nightly (attachment 892582), the
See the align issue in the attachment 8925821 [details] screenshot.

> patch[1] is for fixing it. And the result looks like this attachment 8925830 [details]
> [details].
Comment on attachment 8925818 [details]
Bug 1401442 - Add a hbox to orient help button's icon and text horizontally and match the visual spec.

https://reviewboard.mozilla.org/r/197004/#review203422
Attachment #8925818 - Flags: review?(jaws) → review+
Thank you for the review, Jared.

The treeherder jobs[1] look good. Let's land the patch.

[1]: https://treeherder.mozilla.org/#/jobs?repo=try&revision=e1c4648cfc94
Keywords: checkin-needed
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/2b35a13be867
Add a hbox to orient help button's icon and text horizontally and match the visual spec. r=jaws
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/2b35a13be867
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 58
Whiteboard: [photon-preference][triage]
QA Whiteboard: [good first verify]
You need to log in before you can comment on or make changes to this bug.