Closed Bug 1401458 Opened 3 years ago Closed 3 years ago

Carets are not draggable on iOS 11

Categories

(Firefox for iOS :: General, defect)

Other
iOS
defect
Not set

Tracking

()

VERIFIED FIXED
Tracking Status
fxios 9.1 ---
fxios-v9.0 --- affected
fxios-v9.1 --- verified
fxios-v10.0 --- affected

People

(Reporter: me, Unassigned)

References

()

Details

(Keywords: reproducible)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/60.0.3112.113 Safari/537.36

Steps to reproduce:

With an iPhone 6 with iOS 11 and FireFox for iOS v.9

1. Login to twitter
2. Compose a tweet with the following sentence: "I am going to school"
3. Long press on the caret and try move the caret to the the beginning of the sentence via dragging


Actual results:

The caret is not draggable even if I long pressed on it


Expected results:

The caret can be dragged to the beginning of the sentence
Hi,

Thanks for helping us by reporting this issue, unfortunately I am unable to reproduce this with iPhone 7 iOS 11 running Firefox 9.0(6052) released version. Are you able to reproduce the same issue in Safari?
Flags: needinfo?(me)
First of all, I would like to make a correction: I produce the bug on iPhone 6 Plus but not 6.

***

This bug cannot be reproduced on Safari on my iPhone 6 Plus.

However, I can reproduce it on my iPad Pro 9.7 with Firefox 9

Here is a [video](https://youtu.be/GNQ-HD4TDiM) on how do I reproduce the bug on iPad. I try drag the caret but it is not draggbale.
Flags: needinfo?(me)
FYI, my iPad Pro is running iOS 11 too. 
As you can see in the video, I can drag the caret in the address bar but not the caret in the compose area.
I manage to reproduce this issue on iPhone 7 and iPad Mini 4 both running iOS 11. This was not reproducible on devices running iOS 10. Also note that this issue was also reproduced on facebook.com.
Blocks: ios11
Status: UNCONFIRMED → NEW
tracking-fxios: --- → ?
Ever confirmed: true
Keywords: reproducible
Summary: Carets are not draggable → Carets are not draggable on iOS 11
This issue is not reproducible in Beta 9.1 (6241). This was probably fixed by Bug 1349183.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.