History items change item order in Awesomebar as they are loaded after search suggestions and prepended to the list

RESOLVED DUPLICATE of bug 1391293

Status

()

defect
RESOLVED DUPLICATE of bug 1391293
2 years ago
2 years ago

People

(Reporter: finwe, Unassigned)

Tracking

55 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:55.0) Gecko/20100101 Firefox/55.0
Build ID: 20170824053622

Steps to reproduce:

1. I start typing into the awesomebar. Google is selected as default (and only) search engine
2. A search suggestions appear, the first suits my intention
3. Press key down and enter.


Actual results:

Just before pressing enter, the history items are loaded and as they are prepended to the list, entirely different item is now selected and on pressing enter I end up being on a different page than intended.


Expected results:

The suggestion list should be displayed when the list of items is complete.

Updated

2 years ago
Component: Untriaged → Address Bar
Reporter

Updated

2 years ago
Summary: History items change item order in Awesomebar as they are loaded after search suggesions and prepended to the list → History items change item order in Awesomebar as they are loaded after search suggestions and prepended to the list
Looks like we just fixed this bug in Firefox 57.
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1391293
You need to log in before you can comment on or make changes to this bug.