Closed Bug 1401593 Opened 2 years ago Closed 2 years ago

Transparent elements rendered with flex-direction:column can steal events from <a> tags they are covering.

Categories

(Core :: Layout, enhancement)

enhancement
Not set

Tracking

()

RESOLVED DUPLICATE of bug 102695
Tracking Status
firefox57 --- affected

People

(Reporter: wisniewskit, Unassigned)

References

Details

(Whiteboard: [webcompat])

Attachments

(1 file)

In the attached testcase, Chrome and Safari allow users to click on the anchor tag, but Firefox and Edge do not (you must assign pointer-events:none to the element that is covering it, or otherwise prevent the events from being consumed).

I'm unsure which browsers have the correct behavior, but it's causing a webcompat issue.
Flags: webcompat?
Attached file testcase.html
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 102695
You need to log in before you can comment on or make changes to this bug.