Closed Bug 1401686 Opened 2 years ago Closed 2 years ago

sync error: max_post_bytes is too low

Categories

(Firefox :: Untriaged, defect, P1)

57 Branch
defect

Tracking

()

RESOLVED FIXED
Firefox 57
Tracking Status
firefox-esr52 --- unaffected
firefox55 --- unaffected
firefox56 --- unaffected
firefox57 --- fixed

People

(Reporter: tortino, Assigned: tcsc)

References

Details

(Keywords: regression)

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20170920100426

Steps to reproduce:

just started sync after upgrading to nightly build of 20 sept



Actual results:

1505935530832	Sync.Collection	ERROR	Server configuration max_post_bytes is too low: {"max_post_bytes":1048576,"max_post_records":null,"max_batch_bytes":null,"max_batch_records":null,"max_record_payload_bytes":2097152}
1505935530834	Sync.Status	DEBUG	Status for engine clients: error.engine.reason.unknown_fail
1505935530834	Sync.Status	DEBUG	Status.service: success.status_ok => error.sync.failed_partial
1505935530834	Sync.ErrorHandler	DEBUG	clients failed: Error: Server configuration max_post_bytes is too low (resource://services-sync/record.js:823:13) JS Stack trace: newPostQueue@record.js:823:13 < _uploadOutgoing@engines.js:1658:23 < async*_uploadOutgoing@clients.js:411:11 < async*_sync@engines.js:1765:15 < async*WrappedNotify@util.js:167:27 < async*sync@engines.js:723:12 < async*_syncEngine@enginesync.js:203:13 < async*sync@enginesync.js:84:17 < async*onNotify@service.js:1113:13 < async*WrappedNotify@util.js:167:27 < async*WrappedLock@util.js:123:22 < async*_lockedSync@service.js:1106:12 < async*sync/<@service.js:1098:13 < async*WrappedCatch@util.js:93:22 < async*sync@service.js:1087:12
1505935530834	Sync.Telemetry	TRACE	observed weave:engine:sync:error clients
1505935530835	Sync.Synchronizer	INFO	Updating enabled engines: 9 clients.
This is fallout from bug 1393659 and completely breaks sync :(. Patch incoming (a stopgap to ensure that max_payload_bytes isn't bigger than max_post_bytes).
Assignee: nobody → tchiovoloni
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Priority: -- → P1
Blocks: 1393659
See Also: → 1401707
Comment on attachment 8910493 [details]
Bug 1401686 - Handle cases where max_post_bytes is less than max_record_payload_bytes.

Requesting review from kit instead since mark isn't around and this needs to get in before the merge
Attachment #8910493 - Flags: review?(markh) → review?(kit)
Comment on attachment 8910493 [details]
Bug 1401686 - Handle cases where max_post_bytes is less than max_record_payload_bytes.

https://reviewboard.mozilla.org/r/181894/#review187294

Rubber-stamping to get this in before the merge. It sounds like Bob and Ryan are on board with fixing the client in addition to the server, too.
Attachment #8910493 - Flags: review?(kit) → review+
Pushed by tchiovoloni@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/5fa690493eaa
Handle cases where max_post_bytes is less than max_record_payload_bytes. r=kitcambridge
[Tracking Requested - why for this release]: Sync is completely broken per comment 1.
We've also managed to resolve this via the server - we should take this patch, but Sync is currently no longer broken on 57.
https://hg.mozilla.org/mozilla-central/rev/5fa690493eaa
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 57
Duplicate of this bug: 1401700
You need to log in before you can comment on or make changes to this bug.