Closed Bug 1401701 Opened 4 years ago Closed 4 years ago

Demos on js.devexpress.com can fail to "Copy to Plunker" with stalled tab-loads ever since TLS 1.3 early-data was enabled.

Categories

(Core :: Networking: HTTP, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1397686
Tracking Status
firefox-esr52 --- unaffected
firefox55 --- affected
firefox56 --- affected
firefox57 --- affected

People

(Reporter: wisniewskit, Unassigned)

References

()

Details

STR:

1. Load a demo page on js.devexpress.com, such as https://js.devexpress.com/Demos/WidgetsGallery/Demo/DataGrid/SimpleArray/Angular/Light/
2. While the demo is loading, scroll down and click the "Copy to Plunker" button.
3. Sometimes, the new tab which opens will remain blank indefinitely with "The TLS Handshake finished for embed.pinker.co..." or "Performing a TLS Handshake..." displayed.
4. If the tab does load, close it and reload the original tab with Ctrl+Shift+R, then repeat STR.


I can reproduce this consistently, though it may take a try or two.

Mozregression implicates bug 1342125, and indeed the problem goes away when I disable TLS 1.3 early-data in about:config.
Looking at the log I can confirm that this is dup of bug 1397686. I have a patch for bug 1397686 and I will describe what is the problem there.
Status: NEW → RESOLVED
Closed: 4 years ago
Flags: needinfo?(dd.mozilla)
Resolution: --- → DUPLICATE
Duplicate of bug: 1397686
You need to log in before you can comment on or make changes to this bug.