Closed Bug 1401933 Opened 2 years ago Closed 2 years ago

[Windows 8] Dark theme and light theme background don't apply

Categories

(Firefox :: Theme, defect, P1)

defect

Tracking

()

VERIFIED FIXED
Firefox 58
Tracking Status
firefox56 --- unaffected
firefox57 --- verified
firefox58 --- verified

People

(Reporter: johannh, Assigned: johannh)

References

(Blocks 1 open bug)

Details

(Whiteboard: [reserve-photon-visual])

Attachments

(2 files)

See screenshot. This is the current look of dark and light themes on Windows 8, there's no tab background.

shorlander and I talked about how to best solve this and we think that it would be least ugly to show the theme background inside the tabs, as Windows 7 now does  (only for light and dark theme).

I'll put up a patch.
Flags: qe-verify?
Flags: qe-verify? → qe-verify+
QA Contact: ovidiu.boca
Comment on attachment 8911075 [details]
Bug 1401933 - Make Windows 8 light/dark theme background show up as tab background.

https://reviewboard.mozilla.org/r/182546/#review187846
Attachment #8911075 - Flags: review?(dao+bmo) → review+
Pushed by jhofmann@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/824ab640450f
Make Windows 8 light/dark theme background show up as tab background. r=dao
https://hg.mozilla.org/mozilla-central/rev/824ab640450f
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 58
Comment on attachment 8911075 [details]
Bug 1401933 - Make Windows 8 light/dark theme background show up as tab background.

Approval Request Comment
[Feature/Bug causing the regression]: No particular bug, oversight in the Photon implementation.
[User impact if declined]: Dark and Light themes look a little strange on Windows 8 (the background color of tabs doesn't adjust to the theme).
[Is this code covered by automated tests?]: No, CSS-only.
[Has the fix been verified in Nightly?]: I can see it fixed on Nightly, though I'll leave it to QA to mark the bug VERIFIED.
[Needs manual test from QE? If yes, steps to reproduce]: Enable light or dark theme on Windows 8.
[List of other uplifts needed for the feature/fix]: None
[Is the change risky?]: Not really.
[Why is the change risky/not risky?]: Small CSS change.
[String changes made/needed]: None
Attachment #8911075 - Flags: approval-mozilla-beta?
Comment on attachment 8911075 [details]
Bug 1401933 - Make Windows 8 light/dark theme background show up as tab background.

Polish for photon, taking it into 57b3.
Attachment #8911075 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Duplicate of this bug: 1402696
I verified this issue on Windows 8 x32 and Windows 7 with Build ID 20170925220207.
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:58.0) Gecko/20100101 Firefox/58.0
I will mark this as verified fixed.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
I verified this issue on Windows 8 x32 and Windows 7 x64 using Firefox Beta 57.0b5 with Build ID 20171002181526.
I will mark this as verified fixed.
You need to log in before you can comment on or make changes to this bug.