Closed Bug 1401946 Opened 3 years ago Closed 3 years ago

Show profile path in about:support

Categories

(Firefox :: General, defect)

56 Branch
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 58
Tracking Status
firefox58 --- fixed

People

(Reporter: mozilla, Assigned: mozilla)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:56.0) Gecko/20100101 Firefox/56.0
Build ID: 20170914024831

Steps to reproduce:

Go to about:support.  Look for profile directory.


Actual results:

Instead of showing profile directory, a button to maybe open the profile is shown.


Expected results:

Show the path to the profile directory, perhaps in addition to the button.
Rationale: I rarely want to "open" the profile directory.  Chances are that I already have it in open somewhere, or I need to copy the path into a command line, but I don't know the path.

It's also worth pointing out that the open button might just not do anything, depending on the system configuration:

** (firefox:28760): WARNING **: Cannot launch default application: No application is registered as handling this file
JavaScript error: chrome://global/content/aboutSupport.js, line 1142: NS_ERROR_FAILURE: Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIFile.reveal]

(See also android bug 703298)
You can get this information in about:profiles
(In reply to Pascal Chevrel:pascalc from comment #2)
> You can get this information in about:profiles

Not really, that only shows profiles under ~/.mozilla/firefox/.  Start the browser with |mach run| or pass -profile manually and you'll end up running a profile that will not show up in about:profiles.
Hi mossop, can you review or flag the right person?
Attachment #8910737 - Flags: review?(dtownsend)
Assignee: nobody → mozilla
Status: UNCONFIRMED → ASSIGNED
Component: Untriaged → General
Ever confirmed: true
Comment on attachment 8910737 [details] [diff] [review]
aboutsupport-show-profile-path.patch

Review of attachment 8910737 [details] [diff] [review]:
-----------------------------------------------------------------

I think to keep this looking consistent we should instead turn the button into something that looks like a link showing the profile folder path that when clicked attempts to open it.
Attachment #8910737 - Flags: review?(dtownsend) → review-
> I think to keep this looking consistent we should instead turn the button
> into something that looks like a link showing the profile folder path that
> when clicked attempts to open it.

As another consistency consideration, I would expect things that look like links not to try open some external program.  So I would make it a file:// url (the user.js link is also file://).  This could also be useful on systems where no external program is configured to open directories.  However, this might break workflows, as firefox doesn't really enable file management from within.  What do you think?

I'll note that changing the button into a link will invalidate some documentation, e.g.:
https://support.mozilla.org/en-US/kb/use-troubleshooting-information-page-fix-firefox#w_application-basics
https://support.mozilla.org/en-US/kb/profiles-where-firefox-stores-user-data#w_how-do-i-find-my-profile

Is that okay?
Flags: needinfo?(dtownsend)
Sorry for the delay, I've been mulling this over and flip-flopping between which is the right course of action. I think in retrospect I was wrong to request this be made a link because as you say that implies certain things to the user and I don't think we want to switch to only opening the profile folder in the browser. So let's keep this as a button.
Flags: needinfo?(dtownsend)
Attachment #8910737 - Flags: review- → review+
Keywords: checkin-needed
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/b5da04ce9e43
Show profile path next to the open button. r=Mossop
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/b5da04ce9e43
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 58
You need to log in before you can comment on or make changes to this bug.